C-C TB: calling a builtin Set constructor without new is deprecated and will be forbidden in ES6

RESOLVED DUPLICATE of bug 1129605

Status

Thunderbird
Untriaged
RESOLVED DUPLICATE of bug 1129605
3 years ago
3 years ago

People

(Reporter: ISHIKAWA, Chiaki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
While manually testing local build (DEBUG BUILD) of C-C TB
I noticed a series of the warning messages that are printed by TB into error console.

Warning: calling a builtin Set constructor without new is deprecated and will be forbidden in ES6
Source File: file:///home/ishikawa/objdir-tb3/dist/bin/components/mimeJSComponents.js
Line: 325

"///home/ishikawa/objdir-tb3/" is my MOZ_OBJ directory for the local build.

The line refers to the following piece of code:

   // First, collect all of the emails to forcibly delete.
==> let allAddresses = Set();
    for (let element of this.parseDecodedHeader(aOtherAddrs, false)) {
      allAddresses.add(normalize(element.email));
    }

I think this message was printed when I was doing the manual move of a few messages during  testing filter failures.

TIA

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1129605
You need to log in before you can comment on or make changes to this bug.