There is a gray padding under the page footer in MP homepage

VERIFIED FIXED in 2015-03-03

Status

Marketplace
Consumer Pages
P2
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: ValentinaP, Assigned: ngoke)

Tracking

({regression})

Avenir
2015-03-03
x86_64
Windows 7
regression
Points:
---

Details

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Load MP-stage homepage https://marketplace.allizom.org/
2. Go to the bottom of the page and click “Load more” blue button (one time it's enough)
3. Click any collection (op shelf, ed brand) (i.e. https://marketplace.allizom.org/feed/editorial/apps-for-chile2?src=branded-editorial-element)
4. Click the “go back” arrow from the FF38 browser to load MP-stage homepage again.

Expected results:
There are no display or layout issues.

Actual results:
There is a big gray padding after the page footer.

Notes/Issues:
Verified on FF38 (Win 7). This issue is reproducing on MP-stage and MP-dev. The issue is not reproduced in MP-prod, because there is no “Load more” button (my assumption).
Screencast for this issue http://screencast.com/t/9F02pxnzLU

Updated

3 years ago
Priority: -- → P2
Per ngoke on IRC, we don't restore feed content when navigating back because:

> we manually do pagination and we'd have to manually rewrite cache. we have a bug for it

That's bug 1057103. I believe that's the actual problem here, as the height of the window is maintained specifically so that we can load paginated content and scroll to it. 

Duping against that.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1057103
Based on the screencast, this does not look like a dupe of bug 1057103. That's about maintaining scroll. This is about a huge content area getting added below the main content.

I just reproduced this when I was on an app detail page:

    https://www.dropbox.com/s/m1f3s0tfa9ue529/Screenshot%202015-02-20%2010.18.09.png?dl=0

and pressed back:

    https://www.dropbox.com/s/vbroyn85xz13qv3/Screenshot%202015-02-20%2010.18.04.png?dl=0
Reopening for investigation.

I was unable to get reliable STR, but my STR *I think* did not involve clicking the "Load more" button. But the side effects appear identical.

Btw, I reproduced this twice on desktop (in Firefox). And I reproduced it like 6 times on my iPhone in both Safari and Chrome.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to Christopher Van Wiemeersch [:cvan] from comment #2)
> Based on the screencast, this does not look like a dupe of bug 1057103.

I meant this frame in particular: https://www.dropbox.com/s/0k1togq2tdwd1if/Screenshot%202015-02-20%2013.01.42.png?dl=0
Fwiw, I have been unable to reproduce this without clicking the "load more" button prior to going to an app detail page.
(Assignee)

Updated

3 years ago
Assignee: nobody → kngo
Target Milestone: 2015-02-17 → 2015-02-24
(Assignee)

Comment 6

3 years ago
https://github.com/mozilla/fireplace/commit/714aefbf5f4310ee2fb13b67e78e1e6cda78fea9
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: 2015-02-24 → 2015-03-03
(Reporter)

Comment 7

3 years ago
Verified as fixed on FF39(Win 7) on MP-dev.
Postfix screencast: http://screencast.com/t/FSNkPWe9c6
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.