[Gaia-ui-test][Keyboard] not working in Nexus-5

VERIFIED FIXED in 2.2 S7 (6mar)

Status

defect
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: wachen, Assigned: mnjul)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-v2.5 verified, b2g-master verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
This doesn't work in Nexus5. I think this should be moved out of def switch_to_keyboard(self) in apps/keyboard/app.py, and it should be a different function since switch_to_keyboard should really only contains the action of switching to the keyboard.

input_window = self.marionette.find_element(*self._input_window_locator)
Wait(self.marionette).until(lambda m: 'active' in input_window.get_attribute('class') and input_window.location['y'] == 0, message='Keyboard inputWindow not interpreted as displayed. Debug is_displayed(): %s, class: %s.' % (input_window.is_displayed(), input_window.get_attribute('class')))
(Reporter)

Comment 1

4 years ago
This is block MTBF from running on Nexus5
Blocks: MTBF-2015Q1
John - Do you have a chance to see this issue? thanks
Flags: needinfo?(jlu)
Walter, could you give me more information on "this doesn't work"? Is it that the condition passes even though the keyboard has not showed up, or is it that the condition fails even though the keyboard has showed up, or something else?

Also, do you mean that you always get this, on any kind of tests that use keyboard?

It quite beats me why it doesn't work on a specific hardware; I'll need to hook WebIDE to see what's wrong there. Can I borrow a Nexus 5 from you to check? Thanks.
Flags: needinfo?(jlu) → needinfo?(wachen)
(Reporter)

Comment 4

4 years ago
Hi, I only did. I showed you the code that is not working. Other than that, I have no further information. You can have one device from me.

Yes, almost any kind of tests with keyboard.
Flags: needinfo?(wachen)
(Reporter)

Updated

4 years ago
Flags: needinfo?(jlu)
(In reply to Autolander from comment #5)
> Created attachment 8565293 [details] [review]
> [gaia] mnjul:bug_1133452_gaia_python_ui_test_kb_fail_shb > mozilla-b2g:master

Walter, could you try if this patch resolves the issue for you? Thanks.
Flags: needinfo?(jlu) → needinfo?(wachen)
Assignee: nobody → jlu
(Reporter)

Updated

4 years ago
Flags: needinfo?(wachen)
QA Contact: wachen
(Reporter)

Comment 7

4 years ago
Comment on attachment 8565293 [details] [review]
[gaia] mnjul:bug_1133452_gaia_python_ui_test_kb_fail_shb > mozilla-b2g:master

I think this patch is cool as I verified this morning. Thanks.
Attachment #8565293 - Flags: feedback+
Comment on attachment 8565293 [details] [review]
[gaia] mnjul:bug_1133452_gaia_python_ui_test_kb_fail_shb > mozilla-b2g:master

Hi Dave,

I'd like to ask you to review this patch (we used to have it reviewed by :zacc)  for modification of Python Gaia-UI test scripts.

Keyboard-related mechanisms failed on Nexus 5 because Software Buttons were present and the target "y"-position of Keyboard, according to which we decide the displayed-ness and hidden-ness of the Keyboard, was not what we'd expected.

The test script has been amended to take the software buttons container's height into account by modifying the System app python module to expose such information.

Thanks!
Attachment #8565293 - Flags: review?(dave.hunt)
Comment on attachment 8565293 [details] [review]
[gaia] mnjul:bug_1133452_gaia_python_ui_test_kb_fail_shb > mozilla-b2g:master

Remove r? as Walter told me some tests were still broken.
Attachment #8565293 - Flags: review?(dave.hunt)
(Reporter)

Comment 10

4 years ago
I reconfirmed that it is okay to go. I think I got some failures due to some settings in the CI server. The patch is okay to go.  Thanks so much.
Comment on attachment 8565293 [details] [review]
[gaia] mnjul:bug_1133452_gaia_python_ui_test_kb_fail_shb > mozilla-b2g:master

(In reply to Walter Chen[:ypwalter][:wachen] from comment #10)
> I reconfirmed that it is okay to go. I think I got some failures due to some
> settings in the CI server. The patch is okay to go.  Thanks so much.

Awesome!

Dave, could you review this patch? See comment 8 for details.
Attachment #8565293 - Flags: review?(dave.hunt)
Comment on attachment 8565293 [details] [review]
[gaia] mnjul:bug_1133452_gaia_python_ui_test_kb_fail_shb > mozilla-b2g:master

Looks good. I'd personally prefer the property name software_buttons_height over sw_buttons_height, and a docstring would be great, but r+ as is.
Attachment #8565293 - Flags: review?(dave.hunt) → review+
Since the patch is 1-week old, I rebased the patch and took the opportunity to address Dave's comments. I'm waiting for the Gaia-Try run; Gaia tree is currently closed and I'll land once Gaia re-opens.
(Reporter)

Comment 14

4 years ago
umm... I think this will block nexus5 L build regular MTBF testing. nominating this so that bhavana might have a chance to push it through faster.
blocking-b2g: --- → 2.2?
Flags: needinfo?(bbajaj)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 16

4 years ago
hold on. I think this is not running smooth on nexus5 L v2.2 pvt build.
blocking-b2g: 2.2? → ---

Comment 17

4 years ago
I think this patch works after try more test. Please uplift to v2.2, thanks.
blocking-b2g: --- → 2.2?
Comment on attachment 8565293 [details] [review]
[gaia] mnjul:bug_1133452_gaia_python_ui_test_kb_fail_shb > mozilla-b2g:master

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #): None; it's just that some Python Gaia-UI test scripts had not been written with the idea in mind that they could some day run against a real phone with Software Buttons always enabled.

[User impact] if declined: User is not impacted, but QA work on Nexus 5 such as MTBF/Smoketest/... is severely impacted, as any test involving input from keyboard would break.

[Testing completed]: Yes (also, on Gaia-Try, Gip still greens), and manually verified by QA folks for their purposes.

[Risk to taking this patch] (and alternatives if risky): Minimal. Again this patch only modifies test scripts and no end user-facing mechanisms were changed.

[String changes made]: None
Attachment #8565293 - Flags: approval-gaia-v2.2?
blocking-b2g: 2.2? → 2.2+
Flags: needinfo?(bbajaj)
Attachment #8565293 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified as fixed. I was able to run gaia functional test 'test_keyboard.py' on Nexus 5 passing it without issue.

Verified on:
Build ID               20151124191011
Gaia Revision          7726bfd621d709fa2d179704a44aebc1c309c296
Gaia Date              2015-11-24 15:12:43
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/124375497b14260515e8d2af9c8507a9995b7a47
Gecko Version          44.0a2
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.worker.20151124.181638
Firmware Date          Tue Nov 24 18:16:53 UTC 2015
Bootloader             HHZ12d

Build ID               20151124120300
Gaia Revision          e63c07af8cc636b9ffac2c20f9b8ad7e7fe2b977
Gaia Date              2015-11-24 03:47:05
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/45273bbed8efaface6f5ec56d984cb9faf4fbb6a
Gecko Version          45.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.worker.20151124.111855
Firmware Date          Tue Nov 24 11:19:13 UTC 2015
Bootloader             HHZ12d
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.