Closed Bug 1133506 Opened 5 years ago Closed 5 years ago

[NFC/Secure Element] Update wallet demo code and move it to UI Test

Categories

(Firefox OS Graveyard :: NFC, defect)

x86
macOS
defect
Not set

Tracking

(b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S7 (6mar)
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: tauzen, Assigned: tauzen)

References

Details

Attachments

(2 files)

Secure Element API was finally landed as a certified API in 879861. There were some minor changes in the earlier agreed WebIDL. Current Wallet demo code, which is part of "UI Test - Privileged" app needs to be updated to support latest WebIDL changes and moved to the certified "UI Tests" app.
Assignee: nobody → kmioduszewski
Depends on: 879861, 1034533
Comment on attachment 8565046 [details] [review]
[gaia] tauzen:Bug1133506_wallet_update > mozilla-b2g:master

Hi Tim, since you reviewed the initial version in bug 1034533 could you take a look at this patch? It moves the code to UI Test (API is for certified apps for now) and adds some minor changes to be in line with the final WebIDL.
Attachment #8565046 - Flags: review?(timdream)
Attachment #8565046 - Flags: review?(timdream) → review+
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
Hi Kevin, could you help me out with autolander here? Should I just manually submit a patch to get this landed?
Flags: needinfo?(kgrandon)
(In reply to Krzysztof Mioduszewski[:tauzen] from comment #5)
> Hi Kevin, could you help me out with autolander here? Should I just manually
> submit a patch to get this landed?

Hey - so what should probably happen is that if you are writing NFC code, then you should be a suggested reviewer of the NFC component, which would solve that. Alternatively Tim could be added as a suggested reviewer and that would work too. Basically a suggested reviewer just needs to either request or grant the review. For now I think since this looks testonly and Tim reviewed it we can land manually.

In master: https://github.com/mozilla-b2g/gaia/commit/4352d56f8c79a51eb44e43658472236a38d6f1d8
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(kgrandon)
Resolution: --- → FIXED
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 879861 - SE API was landed as certified, with changes to previously agreed WebIDL. 
[User impact] if declined:
Without this patch Demo Wallet code (Bug 1034533) is not working properly. This does not affect users, since these are changes to test apps only. It should be landed to have the Demo Wallet code consistent with SE API implementation for the sake of developers and QA testing.   
[Testing completed]: On device testing completed.
[Risk to taking this patch] (and alternatives if risky): None (test apps only)
[String changes made]: None
Attachment #8573343 - Flags: approval-gaia-v2.2?
Comment on attachment 8573343 [details] [review]
pull-request-1133506_2.2.txt

I'm having some troubles with one scenario while testing on Nexus 5L. Will ask for approval once everything is clear on my side.
Attachment #8573343 - Flags: approval-gaia-v2.2?
Comment on attachment 8573343 [details] [review]
pull-request-1133506_2.2.txt

Problems mentioned in comment 8 were fixed in Bug 1113054 comment 31.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Bug 879861 - SE API was landed as certified, with changes to previously agreed WebIDL. 
[User impact] if declined:
Without this patch Demo Wallet code (Bug 1034533) is not working properly. This does not affect users, since these are changes to test apps only. It should be landed to have the Demo Wallet code consistent with SE API implementation for the sake of developers and QA testing.   
[Testing completed]: On device testing completed.
[Risk to taking this patch] (and alternatives if risky): None (test apps only)
[String changes made]: None
Attachment #8573343 - Flags: approval-gaia-v2.2?
Comment on attachment 8573343 [details] [review]
pull-request-1133506_2.2.txt

approving as it helps QA and is low risk.
Attachment #8573343 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.