Render bug with div display:inline and absolute placement

RESOLVED DUPLICATE of bug 489100

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 489100
3 years ago
2 years ago

People

(Reporter: Jorg K (GMT+1) [currently bustage-fix only, no NI? or r?], Unassigned)

Tracking

35 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I believe the following page is not rendered correctly:
http://www.jorgk.com/FF-bug/gallery.htm

When the window is wide enough, so both pictures fit horizontally, everything is OK.
When the window is made narrower, the 2nd caption gets placed in a funny place.
If the window width is further reduced, the caption jumps to the correct place.

Chrome and IE do what is expected: The caption is always placed onto the image, at the absolute position specified inside the <div>

I have the impression that the renderer is getting confused. Somehow it thinks it can squeeze some of the text in, but it doesn't quite fit, and the 2nd picture doesn't fit where it tried to squeeze the text in.
Summary: Render bug with div display:block and absolute placement → Render bug with div display:inline and absolute placement
All works well with "display:inline-block" instead of "display:inline".
Obviously the construction with "display:inline" is somewhat invalid, yet, Chrome and IE cope better.
So maybe close the bug as "invalid"?
Component: Untriaged → Layout: Block and Inline
Product: Firefox → Core
Ehsan, could who tell me who looks at layout problems. I reported this problem in February and so far it has received zero attention.
Flags: needinfo?(ehsan)
Jorg, thank you for the bug report.  The zero attention is probably because Firefox:Untriaged has a giant backlog.  :(  In general, if you can figure out a better component than that, chances are the bug will get noticed quicker.

The problem is that we're using the first box of the inline as the absolute containing block, not the bounding rect of all the boxes.  And the second inline starts right after the first inline, _before_ the linebreak.  You can see this if you add a border to the second <div class="gallery-image">.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(ehsan)
Resolution: --- → DUPLICATE
Duplicate of bug: 489100
You need to log in before you can comment on or make changes to this bug.