Mac v35 breaks audio playback in MP4s

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: tom, Unassigned)

Tracking

({html5})

35 Branch
All
Mac OS X
html5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.111 Safari/537.36

Steps to reproduce:

Play back any clip from videoo.com, for example:
http://videoo.com/h/share1love
Press play.  Listen.


Actual results:

Video plays with no sound.


Expected results:

Video should play with sound.
Clips play fine locally in HTML5 player when dropped directly in browser
Clips play fine in Mac 34.0.5, also Chrome, Safari, etc.
(Reporter)

Updated

4 years ago
Keywords: html5
Hardware: x86 → All
I can confirm the issue on my late 2009 mac mini with OSX10.9.5
The ftp server that mozregression is using is at under 10kb/s at the moment and I gave up for today
Status: UNCONFIRMED → NEW
Component: Untriaged → Video/Audio
Ever confirmed: true
Product: Firefox → Core
The linked file has an HE-AAC audio track.  There were a lot of OS X decoder changes around 32, so likely a regression from those.  CCing the appropriate people.
The reporter says that clips play fine in Mac 34.0.5.
(In reply to Masatoshi Kimura [:emk] from comment #3)
> The reporter says that clips play fine in Mac 34.0.5.

Sorry, I meant 35.  We first shipped MP4 support on OS X in 34.
Component: Audio/Video → Audio/Video: Playback
Tested and it works for me. Re-open if this is still an issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.