FetchDriver will never retarget channel thread because nsCORSProxyListener does not support it

RESOLVED DUPLICATE of bug 1196592

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1196592
3 years ago
3 years ago

People

(Reporter: bkelly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
The FetchDriver tries to retarget the channel to the STS event target, but it currently always fails.  This started happening when CORS support was added because nsCORSProxyListener does not implement the nsIThreadRetargetableStreamListener interface.
(Reporter)

Comment 1

3 years ago
Nikhil, I marked this against v2 since it seems like an optimization.  Can you verify that this should not cause a problem in the short term?  Thanks!
Flags: needinfo?(nsm.nikhil)
It won't be a problem, just a perf issue perhaps. Thanks for filing against v2
Flags: needinfo?(nsm.nikhil)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1196592
You need to log in before you can comment on or make changes to this bug.