[EME] Crash in GMPAudioDecoderParent::Close after CDM Error() callback

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: eflores, Assigned: eflores)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Found trying to repro bug 1107241.

Segfault at [1] because mPlugin has already been nulled in ActorDestroy().

[1] https://dxr.mozilla.org/mozilla-central/source/dom/media/gmp/GMPAudioDecoderParent.cpp#143
Oops, caused by not returning after the Error() callback. Shouldn't happen in release since it's in a MOZ_ASSERT. Closing.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.