nsIMsgIncomingServer::GetRootFolder should always return a valid folder!

VERIFIED FIXED in M10

Status

P3
normal
VERIFIED FIXED
20 years ago
10 years ago

People

(Reporter: tonyr, Assigned: scottputterman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Currently, it is required that the creator of the nsIMsgIncomingServer object
manually create a nsIFolder and call SetRootFolder.  In our discussion on
Wednesday (8-5) we decided it would be much better if the incoming server
automatically created the root folder when asked for it.

(Hopefully that describes what we talked about!)
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M10
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 1

20 years ago
I checked in a fix for this.  GetRootFolder will now create the root folder if
it doesn't already exist.
(Assignee)

Comment 2

20 years ago
*** Bug 9145 has been marked as a duplicate of this bug. ***

Updated

19 years ago
QA Contact: lchiang → suresh

Comment 3

19 years ago
Suresh - can you verify at your convenience? Bug 9145 which is a dup of this one
was filed by you.  Thanks.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Using 10/6/99 debug build, tested the JS code. Works fine. Marking Verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.