Attendees Dialog: Autocomplete deforms addresses with e-mail as Display Name

RESOLVED FIXED in 4.0.0.1

Status

Calendar
Lightning Only
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: reyhan.refet, Assigned: MakeMyDay)

Tracking

Lightning 3.8
4.0.0.1
All
Windows 8.1

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150122214805

Steps to reproduce:

I've been able to reproduce this issue so far only with entries in Thunderbird address book who have their e-mail address as display name.
For example:
hitar.petar@example.com <hitar.petar@example.com>
Invite box works fine for addresses who have regular string as display name. For example:
Hitar Petar <hitar.petar@example.com>


Actual results:

Invite Attendees deforms the e-mail address:
"hitar.petar@example.comhitar.petar"@example.com
(for an entry like - hitar.petar@example.com <hitar.petar@example.com>)
Deformed address can not be corrected even manually since Lightning will attempt to autocomplete it and returns the previous value.


Expected results:

As a result of the deformed address, the mail server returns a bounceback. Affected attendees will not receive the intended event notification.
(Reporter)

Updated

2 years ago
Severity: normal → major
OS: All → Windows 8.1
(Assignee)

Comment 1

2 years ago
Does this only happen in Lightning's attendee dialig or also when composing a regular email?
(Reporter)

Comment 2

2 years ago
Hello,

This happens only in Lightning. Composing e-mails works fine.
(Assignee)

Updated

2 years ago
Assignee: nobody → makemyday
Severity: major → normal
(Assignee)

Updated

2 years ago
Summary: Lightning -> Edit Event -> Invite Attendees deforms addresses with e-mail as Display Name → Attendees Dialog: Autocomplete deforms addresses with e-mail as Display Name
(Assignee)

Comment 3

2 years ago
Created attachment 8565631 [details] [diff] [review]
FixAutocompleteDisplayName-V1.diff
Attachment #8565631 - Flags: review?(philipp)
(Assignee)

Updated

2 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8565631 - Flags: review?(philipp) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 4

2 years ago
https://hg.mozilla.org/comm-central/rev/d7c890df28ad

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 4.0
You need to log in before you can comment on or make changes to this bug.