Intermittent black videos on Youtube

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: kael, Unassigned)

Tracking

(Blocks: 1 bug)

37 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(firefox37 affected)

Details

(Reporter)

Description

3 years ago
For the past week or two videos on Youtube have been intermittently appearing as solid black. Audio always works. It's definitely using the <video> player and not the flash one.

I tried disabling mediasource in about:config and that didn't address the issue.

A few things I've noticed:
Usually this video plays an ad when loaded, but any time the page is black no ad plays. Maybe this is from a failed ad load/play since they try to blank out the video behind the ad? Doesn't explain why the video is playing audio, though.

NVidia Geforce GTX 970, latest drivers, Win8.1 x64.

Application Basics
------------------

Name: Firefox
Version: 37.0a2
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Multiprocess Windows: 0/2

...

Adapter Description: NVIDIA GeForce GTX 970
Adapter Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: 4095
Device ID: 0x13c2
Direct2D Enabled: true
DirectWrite Enabled: true (6.3.9600.17111)
Driver Date: 2-5-2015
Driver Version: 9.18.13.4752
GPU #2 Active: false
GPU Accelerated Windows: 2/2 Direct3D 11 (OMTC)
Subsys ID: 39753842
Vendor ID: 0x10de
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 970 Direct3D11 vs_5_0 ps_5_0)
windowLayerManagerRemote: true
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0


I saw a somewhat similar report on Nightly but I couldn't find anything that matched my symptoms. Might be a youtube-side change and not an FF change.
[Tracking Requested - why for this release]:
Youtube regression
tracking-firefox37: --- → ?
Anthony - I'm guessing this is MSE related but don't have proof yet.
Flags: needinfo?(ajones)
Oh. Just realized that the report is from a month ago. We've done a lot of work on MSE in the last month. Does this still reproduce?
Should be fixed by bug 1131638.
Blocks: 778617
Flags: needinfo?(kg)
Flags: needinfo?(ajones)
As this is intermittent as was only fixed last week, we'll have to see if this reproduces over the next week or so. Can you please let us know if you experience any more black screens on YouTube?
I'm clearing tracking as it's not clear that this issue still impacts the release (no other reports) and marking 37 as affected.
status-firefox37: --- → affected
tracking-firefox37: ? → ---
Flags: needinfo?(ajones)
We've blocked a number of video cards which cause a similar sounding problem, but I don't believe we included this one. Are you still seeing this problem?
(Reporter)

Comment 8

3 years ago
I haven't seen this in a while. It might have gone away because I switched to 64-bit Developer Edition.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(kg)
Resolution: --- → FIXED
Flags: needinfo?(ajones)
You need to log in before you can comment on or make changes to this bug.