crash on startup on win 2000

VERIFIED DUPLICATE of bug 108246

Status

()

--
critical
VERIFIED DUPLICATE of bug 108246
17 years ago
16 years ago

People

(Reporter: mikeburba, Assigned: serhunt)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 2000
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (Windows NT 5.0; U)
BuildID:    20011203

Crashing on startup.  I see the splash screen, then I get the Dialog Box that's 
titled, "Program Error".  Message is:  mozilla.exe has produced errors and is 
generating a log file (or words to that effect.

Reproducible: Always
Steps to Reproduce:
1.  Start Browser.  (Double-click on mozilla.exe from File Manager)
2.
3.

Actual Results:  crash...see summary

Expected Results:  Startup

On Windows 2000 Pro SP2 (no hot fixes).  

Sent several talkbacks.  Here are the IDs:

TB38764154G
TB38764071X
TB38532274Y
TB38532045H

Here's the output from some of my Dr. Watson (let me know if you want the whole 
thing):
Microsoft (R) Windows 2000 (TM) Version 5.00 DrWtsn32
Copyright (C) 1985-1999 Microsoft Corp. All rights reserved.



Application exception occurred:
        App: mozilla.exe (pid=7520)
        When: 12/3/2001 @ 22:09:29.127
        Exception number: c0000005 (access violation)

*----> System Information <----*
        Computer Name: xxxxxx
        User Name: Administrator
        Number of Processors: 1
        Processor Type: x86 Family 6 Model 8 Stepping 6
        Windows 2000 Version: 5.0
        Current Build: 2195
        Service Pack: 2
        Current Type: Uniprocessor Free
        Registered Organization: 
        Registered Owner: Michael Burba

*----> Task List <----*
   0 Idle.exe
   8 System.exe
 144 SMSS.exe
 168 CSRSS.exe
 164 WINLOGON.exe
 216 SERVICES.exe
 228 LSASS.exe
 396 svchost.exe
 448 SPOOLSV.exe
 476 PackethSvc.exe
 496 ns-admin.exe
 520 svchost.exe
 548 ftpsched.exe
 560 inetd32.exe
 576 hidserv.exe
 740 OWASTSVR.exe
 860 regsvc.exe
 868 mstask.exe
 900 tcpsvcs.exe
 944 ns-slapd.exe
 980 slapd.exe
1000 WinMgmt.exe
1160 explorer.exe
1336 qagent.exe
1420 WkDetect.exe
1448 HOTSYNC.exe
1384 WkCalRem.exe
1464 OSA.exe
1472 QWDLLS.exe
1492 aoltray.exe
1124 mrtMngr.exe
1520 aim.exe
2152 QW.exe
2824 realplay.exe
3124 hh.exe
2940 CMD.exe
5048 palm.exe
3344 CMD.exe
 284 hh.exe
3336 taskmgr.exe
 764 WINWORD.exe
6880 EXCEL.exe
1404 notepad.exe
7272 notepad.exe
7196 talkback.exe
6816 netscape.exe
7488 IEXPLORE.exe
7520 mozilla.exe
7932 DRWTSN32.exe
   0 _Total.exe

(00400000 - 00457000) 
(77F80000 - 77FFB000) 
(60EF0000 - 60F66000) 
(60DC0000 - 60DC9000) 
(60E30000 - 60E54000) 
(77DB0000 - 77E0B000) 
(77E80000 - 77F35000) 
(77D40000 - 77DB0000) 
(75050000 - 75058000) 
(75030000 - 75043000) 
(78000000 - 78046000) 
(75020000 - 75028000) 
(60EC0000 - 60EC7000) 
(60ED0000 - 60ED6000) 
(782F0000 - 78532000) 
(77F40000 - 77F7C000) 
(77E10000 - 77E74000) 
(70BD0000 - 70C1C000) 
(71700000 - 7178A000) 
(77A50000 - 77B46000) 
(1C000000 - 1C009000) 
(60000000 - 6000C000) 
(60DD0000 - 60DF8000) 
(60010000 - 60024000) 
(60C90000 - 60CA2000) 
(60030000 - 6006B000) 
(60070000 - 600A9000) 
(60CF0000 - 60D40000) 
(600B0000 - 600C1000) 
(600D0000 - 600DE000) 
(600E0000 - 600EE000) 
(600F0000 - 60100000) 
(60100000 - 60113000) 
(60120000 - 6012B000) 
(60130000 - 60147000) 
(60150000 - 601A6000) 
(601B0000 - 601C0000) 
(601C0000 - 601CA000) 
(60220000 - 60246000) 
(601D0000 - 601D5000) 
(013E0000 - 01518000) 
(60320000 - 6033A000) 
(76B30000 - 76B6E000) 
(60340000 - 60426000) 
(60430000 - 60465000) 
(60470000 - 6048C000) 
(77820000 - 77827000) 
(759B0000 - 759B6000) 
(60490000 - 6049E000) 
(604A0000 - 604BF000) 
(779B0000 - 77A4B000) 
(604C0000 - 604C6000) 
(604D0000 - 604D6000) 
(604E0000 - 604E7000) 
(60CD0000 - 60CE5000) 
(60500000 - 60509000) 
(60510000 - 6051F000) 
(60F80000 - 60F8C000) 
(60520000 - 60525000) 
(60530000 - 6053E000) 
(60540000 - 6054D000) 
(60550000 - 6055B000) 
(60560000 - 60573000) 
(60580000 - 60589000) 
(60590000 - 605A6000) 
(605B0000 - 605BA000) 
(605C0000 - 605C9000) 
(605D0000 - 605DD000) 
(605E0000 - 60608000) 
(60610000 - 60618000) 
(60620000 - 60626000) 
(60630000 - 60636000) 
(60640000 - 60662000) 
(60670000 - 60689000) 
(60690000 - 60697000) 
(606A0000 - 606A6000) 
(606B0000 - 606BB000) 
(60E00000 - 60E23000) 
(606C0000 - 606C6000) 
(606D0000 - 60718000) 
(60720000 - 60754000) 
(60760000 - 60771000) 
(60780000 - 607C9000) 
(607D0000 - 607F8000) 
(60800000 - 60829000) 
(60830000 - 60836000) 
(60840000 - 60891000) 
(608A0000 - 608B0000) 
(608B0000 - 608BD000) 
(608C0000 - 608CB000) 
(608D0000 - 608D9000) 
(608E0000 - 608EB000) 
(60D40000 - 60D51000) 
(608F0000 - 608F7000) 
(60900000 - 609B3000) 
(609C0000 - 609C8000) 
(609D0000 - 609DD000) 
(60B00000 - 60B05000) 
(609E0000 - 609F7000) 
(60A00000 - 60A06000) 
(60A10000 - 60A17000) 
(60A20000 - 60A27000) 
(60A30000 - 60A55000) 
(60A60000 - 60A67000) 
(60A70000 - 60A79000) 
(60A80000 - 60A8B000) 
(60A90000 - 60A9B000) 
(60AA0000 - 60ABE000) 
(60AC0000 - 60AC7000) 
(60AD0000 - 60AFC000) 
(01930000 - 0194B000) 
(60B20000 - 60B3B000) 
(60B40000 - 60B5F000) 
(60B60000 - 60B8D000) 
(60B90000 - 60BA7000) 
(60BB0000 - 60BBE000) 
(60BC0000 - 60BCB000) 
(60BD0000 - 60BE2000) 
(60BF0000 - 60BFB000) 
(60C00000 - 60C05000) 
(60C10000 - 60C1A000) 
(60C20000 - 60C45000) 
(60C50000 - 60C73000) 
(60C80000 - 60C8E000) 
(74FD0000 - 74FEF000) 
(75010000 - 75017000) 
(775A0000 - 77625000) 
(77840000 - 7787C000) 
(770C0000 - 770E3000) 
(72A00000 - 72A2D000) 

State Dump for Thread Id 0x1de4

eax=00000000 ebx=00000000 ecx=00000000 edx=01c98f6c esi=00e02f60 edi=00e012e0
eip=6047afc0 esp=0012faf0 ebp=0012fb14 iopl=0         nv up ei pl zr na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00000246


function: nsQueryElementAt::operator=
        6047afa4 7561             jnz     60483b07
        6047afa6 8b4f10           mov     ecx,[edi+0x10]         
ds:0187e8b2=????????
        6047afa9 8b06             mov     eax,[esi]              
ds:00e02f60=60f38e68
        6047afab c1e302           shl     ebx,0x2
        6047afae ff3419           push    dword ptr [ecx+ebx]    
ds:00000000=????????
        6047afb1 6810274860       push    0x60482710
        6047afb6 ff75f8           push    dword ptr [ebp+0xf8]   
ss:00bad0e6=64652f74
        6047afb9 56               push    esi
        6047afba ff5034           call    dword ptr [eax+0x34]   
ds:00a7d5d2=????????
        6047afbd 8b4714           mov     eax,[edi+0x14]         
ds:0187e8b2=????????
FAULT ->6047afc0 8b0403           mov     eax,[ebx+eax]          
ds:00000000=????????
        6047afc3 85c0             test    eax,eax
        6047afc5 741d             jz      NSGetModule+0x3555 (6047ffe4)
        6047afc7 50               push    eax
        6047afc8 e8594a0000       call    NSGetModule+0x2f97 (6047fa26)
        6047afcd 8b5714           mov     edx,[edi+0x14]         
ds:0187e8b2=????????
        6047afd0 59               pop     ecx
        6047afd1 8b0e             mov     ecx,[esi]              
ds:00e02f60=60f38e68
        6047afd3 40               inc     eax
        6047afd4 ff3413           push    dword ptr [ebx+edx]    
ds:01c98f6c=00151648
        6047afd7 50               push    eax
        6047afd8 681c274860       push    0x6048271c

*----> Stack Back Trace <----*

FramePtr ReturnAd Param#1  Param#2  Param#3  Param#4  Function Name
0012FB14 6047AE8E 00000000 000109D7 00013D54 0012FB48 
gkplugin!nsQueryElementAt::operator= 
0012FB90 6047A0AB 00000010 01C9A58C 01C9A588 00000000 
gkplugin!nsQueryElementAt::operator= 
0012FC20 604794A1 00000001 80000000 00BF2578 00000000 
gkplugin!nsQueryElementAt::operator= 
0012FCE0 608E2178 01C9A58C 608E9010 0012FD10 00000000 
gkplugin!nsQueryElementAt::operator= 
0012FD20 608E2584 80000000 608E1DB0 605E4002 00BF2580 
oji!nsGetInterface::operator= 
0012FD28 608E1DB0 605E4002 00BF2580 00B4EFF8 0012FD58 
oji!nsGetInterface::operator=  (FPO: [0,0,1])
0012FD2C 605E4002 00BF2580 00B4EFF8 0012FD58 00C174DC 
oji!nsGetInterface::operator=  (FPO: [3,0,0])
0012FD68 605E40F1 00C174DC 00C174D8 00C17464 605FB408 jsdom!NSGetModule 
0012FD80 605E13A0 01C6EDC0 00C174DC 6013DB8D 01C9A900 jsdom!NSGetModule 
0012FD8C 6013DB8D 01C9A900 01C6EDC0 00C174DC 0012FE20 
jsdom!nsGetInterface::operator=  (FPO: [3,0,0])
0012FDBC 6013184A 01C9A900 0012FE20 0012FE34 0012FE7C docshell!NSGetModule 
0012FDD4 60EF7BAD 00C17460 600BC6A0 0012FE20 00C73138 docshell!NSGetModule 
0012FE04 60F33ED3 600BC6A0 0012FE20 00000000 0012FE4C 
xpcom!nsGetInterface::operator() 
0012FE18 600B6939 00000000 600BC6A0 00C73138 80000000 
xpcom!nsCOMPtr_base::assign_from_helper 
0012FE4C 600B60B5 00C17438 00000000 0012FE78 00000000 
appshell!nsQueryElementAt::operator= 
0012FE88 600B629A 002F3D10 00000000 80000000 00000000 
appshell!nsQueryElementAt::operator= 
0012FEA8 00401640 00C73138 00000000 00133428 00000000 
appshell!nsQueryElementAt::operator= 
0012FEF0 0040121C 00000001 002F2BA8 002F3D10 00133428 
mozilla!nsQueryElementAt::operator= 
0012FF18 0040324B 00000001 002F2BA8 004065E8 00400000 
mozilla!nsQueryElementAt::operator= 
0012FF24 004065E8 00400000 00000000 00133428 00000001 
mozilla!nsQueryElementAt::operator=  (FPO: [4,0,0])
0012FFC0 77E97D08 04F8DDF8 00000000 7FFDF000 C0000005 
mozilla!nsQueryElementAt::operator= 
0012FFF0 00000000 004064B4 00000000 000000C8 00000100 kernel32!CreateProcessW 

*----> Raw Stack Dump <----*
0012faf0  d0 58 e3 60 60 2f e0 00 - e0 12 e0 00 6d 69 6d 65  .X.``/......mime
0012fb00  74 79 70 65 2d 30 00 00 - 40 00 00 00 e1 3e 01 00  type-0..@....>..
0012fb10  00 00 00 00 90 fb 12 00 - 8e ae 47 60 00 00 00 00  ..........G`....
0012fb20  d7 09 01 00 54 3d 01 00 - 48 fb 12 00 48 fb 12 00  ....T=..H...H...
0012fb30  40 00 00 00 b8 8f 48 60 - 10 00 00 00 00 00 00 00  @.....H`........
0012fb40  00 00 00 80 8c a5 c9 01 - 70 6c 75 67 69 6e 2d 31  ........plugin-1
0012fb50  36 00 e3 60 b8 e6 b4 00 - 5d 58 c8 60 b8 e6 b4 00  6..`....]X.`....
0012fb60  00 00 00 00 ff ff 00 80 - 99 3e f3 60 a0 e6 b4 00  .........>.`....
0012fb70  91 26 c8 60 00 00 00 80 - 68 54 f3 60 a0 e6 b4 00  .&.`....hT.`....
0012fb80  90 fb 12 00 a8 e6 b4 00 - 88 a5 c9 01 d7 09 01 00  ................
0012fb90  20 fc 12 00 ab a0 47 60 - 10 00 00 00 8c a5 c9 01   .....G`........
0012fba0  88 a5 c9 01 00 00 00 00 - 74 54 f3 60 50 26 48 60  ........tT.`P&H`
0012fbb0  00 00 00 00 00 00 00 00 - 28 62 f3 60 1c 8e 48 60  ........(b.`..H`
0012fbc0  00 00 00 00 00 00 00 00 - 28 62 f3 60 60 26 48 60  ........(b.``&H`
0012fbd0  00 00 00 00 10 fc 12 00 - 10 62 f3 60 98 26 48 60  .........b.`.&H`
0012fbe0  00 00 00 00 10 fc 12 00 - 00 00 00 00 88 a5 c9 01  ................
0012fbf0  f8 f0 bc 00 f8 f0 bc 00 - 60 2f e0 00 d4 67 2f 00  ........`/...g/.
0012fc00  00 00 00 00 38 a8 c6 01 - b0 a5 c6 01 88 b1 2f 00  ....8........./.
0012fc10  00 00 00 00 d4 fc 12 00 - 18 0a 48 60 14 00 00 00  ..........H`....
0012fc20  e0 fc 12 00 a1 94 47 60 - 01 00 00 00 00 00 00 80  ......G`........

State Dump for Thread Id 0x1b54

Comment 1

17 years ago
Mike, did you install over a previous build ? This is a usual cause for a
problem like yours. Please try the following:
1. Create a new profile.
2. If that doesn't work, uninstall completely (delete Mozilla program directory
or uninstall from Control Panel), then install the latest build. Again, create a
new profile.
(Reporter)

Comment 2

17 years ago
D,
I did not install over a previous build.  I completely delete the "bin" 
directory in my mozilla/dailybuild folder, then unzip the daily win32-talkback 
zip into that folder.

I have used the procedure for quite some time, but only started crashing 
sometime around the 0.9.6 build.

Suspecting a corrupted (or changed by dev team) profiles, I deleted my 
mozreg.dat and nsreg.dat, but that didn't help, either.

Also deleted all the directories in my c:\program 
files\netscape\communicator\users folder as well...hoping there was something 
else I was missing...to no avail.

Are there troubleshooting docs I should read somewhere?

MKB

Updated

17 years ago
Keywords: crash, stackwanted
(Reporter)

Comment 3

17 years ago
Created attachment 60447 [details]
Dr. Watson Log File
(Reporter)

Comment 4

17 years ago
If I need to do something else besides attach the Dr. Watson file, pls let me 
know.  I can figure out how to install and use a differenct debugger, if there 
is one I should be using...or if I'm supposed to start mozilla with some debug 
option to get a stacktrace, let me know.

Thx,
MKB
Talkback's database went kapoot last night, so those IDs arent' findable...
(Reporter)

Comment 6

17 years ago
Wow!  I crashed about 4 more times, trying to figure out how to find out the
talkback build IDs (the ones I listed before were in a window).  Today, after
the first crash, talkback recycled through the report wizard 5 times, then sent
all five talkbacks to the Collector.

Next, I started the Netscape Talkback program from my Start button twice (trying
to find the properties files, so I could display the Talkback IDs).

Then, all of a sudden, I tried mozilla again, and the program started up!!?  I
can't get it to crash again.

Could it be that I was crashing because my build was talkback and the db was down?

If so, think this should still be a bug, because mozilla startup should not have
a talkback dependency...

If there's something I can do to help debug, let me know.
MKB

Comment 7

17 years ago
unlikely that talkback had anything to do with a mozilla crash.
(your talkback stack trace:)

AddPluginInfoToRegistry
[d:\builds\seamonkey\mozilla\modules\plugin\base\src\nsPluginHostImpl.cpp, line
4934]
nsPluginHostImpl::CachePluginsInfo
[d:\builds\seamonkey\mozilla\modules\plugin\base\src\nsPluginHostImpl.cpp, line
5145]
nsPluginHostImpl::LoadPlugins
[d:\builds\seamonkey\mozilla\modules\plugin\base\src\nsPluginHostImpl.cpp, line
4710]
nsPluginHostImpl::GetPluginFactory
[d:\builds\seamonkey\mozilla\modules\plugin\base\src\nsPluginHostImpl.cpp, line
4279]
nsJVMManager::StartupJVM
[d:\builds\seamonkey\mozilla\modules\oji\src\nsJVMManager.cpp, line 672]
nsJVMManager::MaybeStartupLiveConnect
[d:\builds\seamonkey\mozilla\modules\oji\src\nsJVMManager.cpp, line 903]
nsJVMManager::StartupLiveConnect
[d:\builds\seamonkey\mozilla\modules\oji\src\nsJVMManager.h, line 145]
nsJSEnvironment::Init
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1678]
NS_CreateScriptContext
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1720]
nsDOMSOFactory::NewScriptContext
[d:\builds\seamonkey\mozilla\dom\src\build\nsDOMFactory.cpp, line 137]
nsDocShell::EnsureScriptEnvironment
[d:\builds\seamonkey\mozilla\docshell\base\nsDocShell.cpp, line 5721]
nsWebShell::GetInterface
[d:\builds\seamonkey\mozilla\docshell\base\nsWebShell.cpp, line 306]
nsGetInterface::operator()
[d:\builds\seamonkey\mozilla\xpcom\base\nsIInterfaceRequestor.cpp, line 55]
nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 81]
nsAppShellService::GetHiddenWindowAndJSContext
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 613]
nsAppShellService::SetXPConnectSafeContext
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 193]
nsAppShellService::CreateHiddenWindow
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 293]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1237]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1602]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1620]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 

You're not seeing this anymore? Plugins folks, this might already be fixed. 
Assignee: asa → av
Status: UNCONFIRMED → NEW
Component: Browser-General → Plug-ins
Ever confirmed: true
QA Contact: doronr → shrir
(Assignee)

Comment 8

17 years ago
I think this is a dup of bug 108246. Marking as such. Reporter, if this is not 
please reopen.

*** This bug has been marked as a duplicate of 108246 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 9

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.