Closed Bug 113383 Opened 23 years ago Closed 23 years ago

link to dependent bug in "dependent bug changed state" notification

Categories

(Bugzilla :: Email Notifications, defect)

2.15
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Bugzilla 2.16

People

(Reporter: myk, Assigned: myk)

References

Details

Attachments

(2 files, 2 obsolete files)

When a bug on which another bug depends changes state, users on the dependant
bug get email about it.  The email contains a link to the dependant bug but does
not contain a link to the depending bug.  It should.
This patch adds a link to the depending bug and clarifies the message
explaining what has happened.  This fix should also be incorporated into the
fix for bug 65477 via linkification of the "bug xxx" text rather than a
separate link underneath that text.
reassigning to patch author
Assignee: jake → myk
Status: NEW → ASSIGNED
Comment on attachment 60281 [details] [diff] [review]
patch v1: adds link and clarifies explanatory text

You changed from "This bug" to "Bug $id". Was that intentional? I don't think
one is better over teh other, so r=bbaetz. Second reviewer should test this,
since I can't ATM.
Attachment #60281 - Flags: review+
>You changed from "This bug" to "Bug $id". Was that intentional?

Yes.  I have often found the phrase "This bug" to be confusing in emails about
depending bug state changes because the bug to which the pronoun "this" refers
is not explicitly named in the body of the message.  Its bug number and summary
appears in the subject line, and a link to the bug appears in the body, but
these references have been insufficient to enable me to understand the pronoun's
referent.  Explicitly naming the bug instead of using the pronoun makes things
clearer.

I can change the wording back and file a new bug on it if there is controversy
over the wording, but otherwise the change is so small that we might as well
roll them together.
Comment on attachment 60281 [details] [diff] [review]
patch v1: adds link and clarifies explanatory text

>+              "\nBug $id depends on bug $bug, which changed state.\n\n" . 
>+              "$urlbase/show_bug.cgi?id=$bug\n\n" . 
>+              "Bug $bug Summary: $summary\n\n";

Shouldn't it just be a single \n instead of \n\n at the end of the first two
lines?

Also, why not put the URL as the 3rd line?  This way you can read both
informative lines
and the link is neatly at the bottom?
>Shouldn't it just be a single \n instead of \n\n at the end of the first two
>lines?

Sure, why not.

>Also, why not put the URL as the 3rd line?  This way you can read both
>informative lines
>and the link is neatly at the bottom?

Works for me.

This patch contains these two formatting changes.
Attachment #60281 - Attachment is obsolete: true
Attachment #63972 - Attachment is patch: false
Attachment #63972 - Attachment mime type: text/plain → image/png
Attachment #63965 - Attachment is obsolete: true
Comment on attachment 63974 [details] [diff] [review]
patch v3: fixes the extra slash problem

r=caillon
Attachment #63974 - Flags: review+
it's cheap, it's easy, let's get it in to 2.16!
Target Milestone: --- → Bugzilla 2.16
Comment on attachment 63974 [details] [diff] [review]
patch v3: fixes the extra slash problem

Looks good to me...
r=jake
Attachment #63974 - Flags: review+
Checking in processmail;
/cvsroot/mozilla/webtools/bugzilla/processmail,v  <--  processmail
new revision: 1.74; previous revision: 1.73
done
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
*** Bug 146476 has been marked as a duplicate of this bug. ***
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: