Closed Bug 1133847 Opened 5 years ago Closed 5 years ago

Labels for toggle switches get clipped if they need to wrap across 2+ lines

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

x86_64
Linux
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S6 (20feb)
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: sfoster, Assigned: sfoster)

Details

(Keywords: l12y, Whiteboard: systemsfe)

Attachments

(3 files)

For longer/larger labels for toggle switches in the FTU, the 2nd line is partially clipped and obscured. The attachment shows this for both Arabic (RTL) and the accented-english pseudo-locale
Keywords: l12y
Assignee: nobody → sfoster
blocking-b2g: --- → 2.2?
Comment on attachment 8566601 [details] [review]
[gaia] sfoster:ftu-toggle-switch-height-bug-1133847 > mozilla-b2g:master

We had fixed heights on list items and the packed-switch label. The [data-type="list"] li change wants close checking to be sure nothing regressed elsewhere. I've run through the FTU in US-English, Arabic and Accented English locales/languages and all looks good to me though.
Attachment #8566601 - Flags: review?(fernando.campo)
blocking-b2g: 2.2? → 2.2+
Attachment #8566601 - Flags: review?(fernando.campo) → review+
Keywords: checkin-needed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8566601 [details] [review]
[gaia] sfoster:ftu-toggle-switch-height-bug-1133847 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): FTU/RTL
[User impact] if declined: In Arabic as well as verbose locales, longer labels on toggle switches in the FTU may be clipped and made illegible
[Testing completed]: Gaia-Try is green, tested on device with Arabic and Accented English
[Risk to taking this patch] (and alternatives if risky): Risk should be low (change is CSS-only, FTU-only), but one of the CSS rule updates affects all data-list items in the FTU.
[String changes made]: None
Attachment #8566601 - Flags: approval-gaia-v2.2?
Target Milestone: --- → 2.2 S6 (20feb)
Attachment #8566601 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been successfully verified on latest Flame v2.2&3.0.
See attachment: verified_v2.2&3.0.png
Reproduce rate: 0/5

STR

Flame 2.2 (Pass):
Build ID               20150319002500
Gaia Revision          9043c11f699c15bb6072422d1dad6518d1b5ddda
Gaia Date              2015-03-19 01:40:44
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c0442d170bec
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.042028
Firmware Date          Thu Mar 19 04:20:38 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (Pass):
Build ID               20150319160212
Gaia Revision          c39e15f631de80c69467fda0d4ea0bcda9e194ca
Gaia Date              2015-03-18 19:30:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cbd0efcd976c
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150319.193329
Firmware Date          Thu Mar 19 19:33:42 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Keywords: verifyme
Attached image verified_v2.2&3.0.png
Add verified STR:
1.Reset or flash to go to FTU.
2.Change language to "Arabic",or other languages.
3.Keep tapping "Next" button to verify these pages in FTU.
**They are not clipped and display normally when they need to wrap across 2+ lines.
QA Whiteboard: [MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.