On Windows 7, the installer of TB 31.5.0 and 36 Beta 1 needs to be run as administrator

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: jorgk, Unassigned)

Tracking

36 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I installed on Win7 and got this message when trying to install:
"You may not have the necessary permissions to use all the features of the program you are about to run. You may run this program as a different user or continue to run the program as the current user."

It wouldn't install under the current user account, I had to run the installer as Administrator. I guess that won't be appreciated by the user base where the common user isn't even aware of Window's administrator account.
(Reporter)

Comment 2

4 years ago
I've just installed TB 31.5.0 and the installer wanted to run as administrator.
That won't be popular with users.
Summary: On Windows 7, the installer of TB 36 Beta 1 needs to be run as administrator → On Windows 7, the installer of TB 31.5.0 and 36 Beta 1 needs to be run as administrator

Comment 3

4 years ago
James, can you reproduce this, or  Bug 1132840 ?
Flags: needinfo?(jamesrome)
(Reporter)

Comment 4

4 years ago
I've just tried an "automatic" update from 24.6 to 31.5 on another Windows 7 machine and during this process no admin rights were necessary. Of course this is different to a "fresh" install using an installer (which is the subject of this bug).
Jorg, can you try a previous version to see if that also happens with it?
Flags: needinfo?(mozilla)
(Reporter)

Comment 6

4 years ago
I tried three previous versions: TB 24, TB 31.4 and FF 30. They all request administrator rights now. Damn. Something has changed on my system since these installed without admin rights before. However, I'm not the only one. If I google the message given in the original description "You may not have the necessary permissions ..." I can see many people have problems installing Firefox. So how do we get to the bottom of this?
Flags: needinfo?(mozilla)
The first step would be to figure out what changed on your system
(Reporter)

Comment 8

4 years ago
OK, I found it. There was something fishy with the UAC settings. They were I the highest level ("always notity") although I can't remember setting this. So I moved them back to the default level and the problem went away. Then I moved them back to the highest level and lo and behold, the problem DID NOT return. So only Microsoft in their infinite wisdom can know what went on here. Some internal minor corruption which was fixed by shifting the UAC level around. I'll close the bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 9

4 years ago
Huh? I did not chip in on this bug, and do not have the problem.
Flags: needinfo?(jamesrome)
You need to log in before you can comment on or make changes to this bug.