Sign in is broken on marketplace prod after enabling the native flow

VERIFIED FIXED in 2015-02-24

Status

Marketplace
Consumer Pages
--
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: krupa, Unassigned)

Tracking

2015-02-24
x86
Gonk (Firefox OS)
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Connectivity: wifi
SIM used: Poland DT
Gaia/device: 2.1/flame; 20150213001208; 34.0: git commit info: e8eba437


steps to reproduce:
1. If there are any pending updates for Marketplace, install them.
2. Go to Settings app ->Account Management
3. Sign in using FxA
4. Load Marketplace prod

expected behavior:
User is signed into marketplace prod since native flow is supported for 2.1

actual behavior:
User is not signed in to marketplace.

Clicking 'Sign in' from marketplace does nothing effectively blocking the user from logging into marketplace. There are no requests made when user clicks 'Sign in'.
(Reporter)

Comment 1

3 years ago
screencast: http://cl.ly/3f202n0m2S08
The Marketplace app in the 2.1 Gaia builds I have seen do not include the native FxA  code, resulting in this behavior.
(Reporter)

Comment 3

3 years ago
(In reply to Allen Short [:ashort] from comment #2)
> The Marketplace app in the 2.1 Gaia builds I have seen do not include the
> native FxA  code, resulting in this behavior.

I got an update for marketplace prod which I applied. Shouldn't that fix the issue then?
Flags: needinfo?(ashort)
https://github.com/mozilla/marketplace-core-modules/commit/5e9701f1acdbedc2aea63dbbe14ad1e42b9b572f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(ashort)
Resolution: --- → FIXED
Target Milestone: --- → 2015-02-24

Comment 5

3 years ago
I still can reproduce this issue using the original steps. I have downloaded the update for marketplace but still after sing in from the phone settings and opening the marketplace production app I am not logged in.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 6

3 years ago
Was fixed in the push today.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED

Comment 7

3 years ago
Appears to be working now, I could successfully log in into the production app. There is a small issue when tapping the "Create an account or sign in" or when completing the sign in there is a page loading with the title iStage. 

Attaching a video with this issue.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

3 years ago
Created attachment 8569260 [details]
nativeFlow_FFOS2_1.mp4
krupa says this is fixed
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

3 years ago
(In reply to Madalin Cotetiu from comment #7)
> Appears to be working now, I could successfully log in into the production
> app. There is a small issue when tapping the "Create an account or sign in"
> or when completing the sign in there is a page loading with the title
> iStage. 
> 
> Attaching a video with this issue.

If you still see this issue, please file a separate issue.

Comment 11

3 years ago
Sign in works, also I couldn't reproduce anymore the issue from comment 7.
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.