DISABLED attribute not supported on OPTION element

VERIFIED FIXED in M10

Status

()

Core
HTML: Form Submission
P2
normal
VERIFIED FIXED
20 years ago
12 years ago

People

(Reporter: Angus Davis, Assigned: rods (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

20 years ago
The disabled attribute works almost everywhere (terrific!) but not yet on the
OPTION element. A test case is available at the URL given. It doesn't work right
in ie5b1 either.

Updated

20 years ago
Status: NEW → ASSIGNED

Updated

20 years ago
Assignee: karnaze → kmcclusk
Status: ASSIGNED → NEW

Comment 1

20 years ago
The widget library does not support combo boxes or list boxes having disabled
elements.
(Reporter)

Comment 2

20 years ago
Adding hyatt to the cc list; he may be interested in this.

Updated

20 years ago
Assignee: kmcclusk → karnaze

Updated

20 years ago
Assignee: karnaze → kmcclusk

Comment 3

20 years ago
reassigning back to Kevin a 2nd time. This is a limitation of the widget
library.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 4

20 years ago
Setting all current Open/Normal to M4.

Comment 5

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

20 years ago
QA Contact: 4110 → 4137

Comment 6

20 years ago
Reassigning qa contact to cpratt@netscape.com

Updated

20 years ago
Target Milestone: M4 → M5

Updated

20 years ago
Target Milestone: M5 → M7
This will be fixed for GFX-rendered option elements only.
*** Bug 3596 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Target Milestone: M7 → M8

Updated

19 years ago
Target Milestone: M8 → M10

Updated

19 years ago
Assignee: kmcclusk → rods
Status: ASSIGNED → NEW
Rod, re-assigning to you. This is a general bug related to gfx-rendered form
elements.
(Assignee)

Updated

19 years ago
Depends on: 11466
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
Fixed.

Updated

19 years ago
Whiteboard: 23-Aug-99: will verify in M10 w/GFX later this week

Updated

19 years ago
Status: RESOLVED → REOPENED
Whiteboard: 23-Aug-99: will verify in M10 w/GFX later this week

Comment 11

19 years ago
I can't verify the fix using the 1999082616 build with GFX widgets under NT.
When I look at the Select with one disabled option, 'Two fish' is as selectable
as anything else in the list. Reopening bug and clearing resolution.

[If it helps, I was looking for one of two behaviors: either you can't click on
the Two fish option to select it, or, if you can, going on in the form should
switch it back to whatever was previously selected.]

Updated

19 years ago
Resolution: FIXED → ---
(Assignee)

Comment 12

19 years ago
Created attachment 1458 [details]
New test example that shows it with a button and some text
(Assignee)

Comment 13

19 years ago
Ignore this lastest attachment it was for a different bug.
(Assignee)

Comment 14

19 years ago
Created attachment 1470 [details]
Form with everything disabled
(Assignee)

Comment 15

19 years ago
Created attachment 1473 [details]
This one has them all disabled
(Assignee)

Comment 16

19 years ago
Attachment 1470 [details] is incorrect, use the lastest one 1473
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

19 years ago
Fixed.

Updated

19 years ago
Status: RESOLVED → REOPENED

Updated

19 years ago
Resolution: FIXED → ---

Comment 18

19 years ago
I still don't see the fix (using the 1999090708 build under NT). Both
partial-gfx and gfx (in the Preferences) allow me to select Two fish with no
problems. Reopening bug and clearing resolution.
(Assignee)

Comment 19

19 years ago
What example are using to test this with? You should attach your testing example
or use mine. I am not seeing the problem you are seeing.

Comment 20

19 years ago
I am using the test case at the URL in this bug report. The sample code in
question is:

<select id="myselect">
<option>One fish
<option disabled>Two fish
<option>Red fish
<option>Blue fish
</select>

If I understand this correctly, 'Two fish' should be visually greyed out, and
not selectable. It looks exactly the same as the other options, and is
selectable using both GFX and native widgets.
(Assignee)

Updated

19 years ago
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 21

19 years ago
Ok, it is REALLY fixed this time.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 22

19 years ago
Beautiful! Verified fixed in the 1999091310 Win32 build (on NT).

Comment 23

12 years ago
kjhkjhk
You need to log in before you can comment on or make changes to this bug.