Closed Bug 1134005 Opened 5 years ago Closed 5 years ago

[Marketplace][Twitter] When Twitter is installed to the homescreen through the marketplace, a Rocketship icon is seen in its place

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 verified, b2g-v2.2 verified, b2g-master verified)

RESOLVED FIXED
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- verified
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: dharris, Assigned: mellis)

References

()

Details

(Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Attached file Twitter Icon Logcat
Description:
If the user installs the twitter app from the marketplace, the icon on the homescreen appears as a grey rocketship. If the user installs twitter from Smart Collections, or by adding to the homescreen, the blue bird twitter icon is seen properly.


Repro Steps:
1) Update a Flame to 20150217074222
2) Open Marketplace App
3) Search for "Twitter"
4) Install the Twitter app> Go to homescreen


Actual:
The twitter app is installed but the icon is not shown properly. A rocket ship icon can be seen in its place.


Expected:
The twitter Icon is properly placed on the homescreen.

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150217074222
Gaia: ae02fbdeae77b2002cebe33c61aedeee4b9439fd
Gecko: 4bb425001d8a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/kxoS1YzsDgw
This issue DOES occur on Flame 2.2, Flame 2.1, and v18D-1 Base Image

A rocket ship icon can be seen in place of the Twitter icon

Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150213002503
Gaia: ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gecko: d04b78eeb536
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150217001459
Gaia: e8eba437af02820f74d122aec83b6001df6f89e3
Gecko: 9d04f9149ca4
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Device: Flame Base v18D-1 (319Mb)(Kitkat)
Build ID: 20150106124450
Gaia: 79f6218c4f30c2739575c3ab800078c2cda135cb
Gecko: d9d4000dd43a3637345a41d716dc97fdd700d715
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Moved this to our primary channel for reporting/filing 3rd party Marketplace app issues.

Marketplace>Preinstalled Apps is primarily used by FFOS partners to request permission to preload a specific set of apps for an upcoming launch.

Added Michael Ellis to CC. Please be sure to NI Michael if any interaction with Twitter is needed or if this issue looks to be within the app itself.

Also added to Twitter blocker bug.
Blocks: b2g-twitter
Component: Pre-Installed Apps → Preinstalled B2G Apps
Product: Marketplace → Tech Evangelism
Version: Avenir → unspecified
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
blocking-b2g: --- → 2.2?
Duplicate of this bug: 1134761
From bug 1134761 comment 8:
> So just looked into this, the problem is that the icons specified for the
> manifest no longer exist.
> 
> You can find the manifest here:
> https://mobile.twitter.com/cache/twitter.webapp
> 
> The icons are /images/larrybird-30.png (and -60 and -128), none of which
> exist on that domain anymore.
Thanks Kevin, 

Twitter is currently in the process of reworking their backend.  As such, they have limited resources at this time for partner bugs, but we will reach out to the Twitter through our BD relationship and see if we can get a fix.

@Didem - Can we reach out to Jeremy and see if we can get their attn on this matter?
Assignee: nobody → mellis
Status: NEW → ASSIGNED
Flags: needinfo?(dersoz)
Hi Twitter informed us they fixed the issue. I confirmed on a Flame device that it is resolved.
Flags: needinfo?(dersoz)
Thanks Didem!
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Keywords: verifyme
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
This issue is verified fixed on Flame Master, 2.2, and 2.1.

Result: The Twitter icon appears properly on the homescreen.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150317073344
Gaia: 738987bd80b0ddb4ccf853855388c2627e19dcc1
Gecko: 008b3f65a7e0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150317002504
Gaia: d0e09d5e6367e558824f9cbf691da99cedf63037
Gecko: 793d61bb0bd4
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.1  (KK, 319mb, full flash)
Build ID: 20150317001200
Gaia: e53469fe3a5e563a9146d0fb028e544a423b7e96
Gecko: 32d1cae787e0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1150198
Duplicate of this bug: 1150198
Bug 1150198 closed as a duplicate of this bug. Reopening this bug as issue is reoccurring. 

"Thank you for reporting this issue, Gregor.  I have also confirmed that the twitter app is again displaying the default rocketship icon instead of "Larry Bird".

@Didem - Can we send an email over to Jeremy and inform him of this issue?
Status: VERIFIED → REOPENED
Flags: needinfo?(dersoz)
Resolution: FIXED → ---
Duplicate of this bug: 1154630
Dear Didem,
Could you help to check comment 10 from Michael? This is blocking 2.2 release bug. Thanks
Didem sent the email to Twitter, will update when we hear back
This issue was resolved today.
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Flags: needinfo?(dersoz)
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.