Closed Bug 1134035 Opened 5 years ago Closed 5 years ago

[Dialer] Tapping the top call log entry, selects and deselects the 2nd call entry in edit mode

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect, P3)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: KTucker, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing][systemsfe])

Description:
The user will notice that when they tap on the top call log entry while in edit mode that the second call log entry will be selected/deselected.

Prerequisite: 3 call entries recorded in the call log.

Repro Steps:
1) Update a Flame device to BuildID: 20150217074222.
2) Open "Dialer".
3) Tap on the "Call Log" icon.
4) Tap on the "Edit" button while on the "All" tab.
5) Tap on all 3 call logs to select them. 
6) Repeatedly tap on the "checkmark box" on the top call log entry, paying close attention to the second call log entry.

Actual:
When the user taps on the top call log entry in edit mode, it will select/deselect the second call log entry.
  
Expected: 
Only the top call log is selected/deselected when tapped on.

Environmental Variables:
Device: Flame 3.0 (Full Flash)(KK)(319mb)
Build ID: 20150217074222
Gaia: ae02fbdeae77b2002cebe33c61aedeee4b9439fd
Gecko: 4bb425001d8a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
  
Repro frequency: 100%
See attached: video
Can we get a branch check on this please?
QA Whiteboard: [
Keywords: qawanted
Also a video.
No longer blocks: music-rtl
QA Whiteboard: [
No longer depends on: 1119596
Whiteboard: [3.0-Daily-Testing]
QA Contact: ychung
It seems like the issue only reproduces when the user taps on the right edge of the screen.

Video: http://youtu.be/DIRCCKxRiXE

-------------------------------
This issue does NOT reproduce on Flame 2.2.

Result: Only the selected item is checked when the user taps anywhere within the area.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150217140306
Gaia: 31490848a35f1c6a893ad77186151edb8a4dc3f1
Gecko: 4529c71a3e0c
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawantedregression
QA Contact: ychung
[Blocking Requested - why for this release]:

Nominating 3.0? since this is a regression and could lead to end user frustration.
blocking-b2g: --- → 3.0?
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
QA Contact: ychung
*** Correcting branch check ***

In order to reproduce this issue, the device has to be locked and unlocked at least once before step #6 from comment 0. Following the correct STR, the issue DOES reproduce on Flame 2.2.

Result: When selecting an item, the one below is checked. 

Environmental Variables:
Device: Flame 2.2
BuildID: 20150217140306
Gaia: 31490848a35f1c6a893ad77186151edb8a4dc3f1
Gecko: 4529c71a3e0c
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
---------------------------------
This issue does NOT reproduce on Flame 2.1.

Result: Only the selected item is checked when the user taps anywhere within the area.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150217142614
Gaia: 0d4b3c63d5cfb01f3312675f85c5ee43a0836d6b
Gecko: f61986c6df4d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
----------------------------------
I'll continue working on the regression window.
Just confirmed this, it seems that the hit-box of each call log entry is not as wide as the screen leaving two small areas to the left and right of it. Tapping each one seems to cause the problem in a consistent way.
Regression per comment 5 and 6.
blocking-b2g: 3.0? → 2.2?
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150203043327
Gaia: ed2b99f7ba4a4517d0aa7d08b9f3d783181acd9a
Gecko: 60ff87d49efb
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150203063725
Gaia: 9093ccc0c909c6977bbaaf570c0728bc12d75a3d
Gecko: ea24223ba980
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: ed2b99f7ba4a4517d0aa7d08b9f3d783181acd9a
Gecko: ea24223ba980

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 9093ccc0c909c6977bbaaf570c0728bc12d75a3d
Gecko: 60ff87d49efb

https://github.com/mozilla-b2g/gaia/compare/ed2b99f7ba4a4517d0aa7d08b9f3d783181acd9a...9093ccc0c909c6977bbaaf570c0728bc12d75a3d

caused by bug 1128672
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Etienne, can you take a look at this please? Looks like this was caused by the work done on bug 1128672
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(etienne)
blocking-b2g: 2.2? → 2.2+
Blocks: 1128672
Component: Gaia::Dialer → Gaia::System::Window Mgmt
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
This is likely fixed by bug 1131695, I will be requesting uplift on that soon.
Flags: needinfo?(etienne)
qawanted to verify comment 10.
Keywords: qawanted
This issue is verified fixed on Flame Master.

Result: Only the selected item is checked.
 
Device: Flame Master (KK, 319mb, full flash)
Build ID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
============================
Leaving verifyme for 2.2 verification when the patch for bug 1131695 is uplifted on nightly.
Status: NEW → RESOLVED
Closed: 5 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawantedverifyme
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Resolution: FIXED → WORKSFORME
Verifying issue is fixed on latest Flame 2.2 nightly build.

Actual Results: Only the top call log is selected/deselected when tapped on.

The patch for bug 1131695 has been uplifted successfully on nightly (see comment 12).  Further, I activated "Flash repainted areas" to make sure the second call in the call log is NOT selected when the user taps on the first entry. 

Environmental Variables:
Device: Flame 2.2
BuildID: 20150811032503
Gaia: 102f1299e9eafe3760e1deb44d556b5c4f36b5af
Gecko: 13c447ed929e
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Contact: ddixon
Resolution: WORKSFORME → FIXED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.