If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash trying to open this secure page

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: hico2, Assigned: Marc Attinasi)

Tracking

({crash})

Trunk
mozilla1.2alpha
x86
Windows NT
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.6+) Gecko/20011129
BuildID:    2001120303

Mozilla builds for past two months crash on our sqwebmail page.

Reproducible: Always
Steps to Reproduce:
1. type https://mail.fphil.uniba.sk in the location bar
2. press Enter
3. if certificate warning pops up, choose Yes

Actual Results:  browser crash

Expected Results:  getting sqwebmail login page, same as it works in Explorer

Just tried to send talkback data from the crash. This thing may be related to
#90362. Also an english version of the page is available,
https://mail-en.fphil.uniba.sk. I'm the site's webmaster, server is standard
apache-ssl from debian potato. Please tell me what to look for if more data is
needed.
(Reporter)

Comment 1

16 years ago
This talkback didn't get through, talkback.netscape.com is not responding.
There should be one talkback of the same crash from 2001112603, that one 
seemed to get through.

Comment 2

16 years ago
WFME on win2k build 2001120303

Comment 3

16 years ago
I also crashed using build 2001120303 on Win2k. Talkback ID to be sumbmitted
when Talkback server back on-line.
Keywords: crash

Comment 4

16 years ago
I crashed as well with Mozilla 0.9.6 (2001112009) / NT4 SP6
looks like a dupe of bug 104804

-> Layout (should be a dupe but I'm not sure because this has nothing to do 
with tabs)


win2k stack trace :

NTDLL! 778a018c()
nsWindow::Create(nsWindow * const 0x0542ee3c, nsIWidget * 0x0562a5fc, const 
nsRect & {...}, nsEventStatus (nsGUIEvent *)* 0x01f645b0 HandleEvent(nsGUIEvent 
*), nsIDeviceContext * 0x0564cd90, nsIAppShell * 0x00000000, nsIToolkit * 
0x00000000, nsWidgetInitData * 0x0012ec7c) line 1312
nsView::CreateWidget(nsView * const 0x0542b120, const nsID & {...}, 
nsWidgetInitData * 0x0012ec7c, void * 0x00000000, int 1, int 1) line 900
nsScrollPortView::CreateScrollControls(nsScrollPortView * const 0x0542b180, void 
* 0x00000000) line 176
nsScrollBoxFrame::CreateScrollingView(nsIPresContext * 0x05650178) line 314
nsScrollBoxFrame::Init(nsScrollBoxFrame * const 0x0569a2a4, nsIPresContext * 
0x05650178, nsIContent * 0x00000000, nsIFrame * 0x0569a15c, nsIStyleContext * 
0x0569a210, nsIFrame * 0x00000000) line 115
nsCSSFrameConstructor::ConstructRootFrame(nsCSSFrameConstructor * const 
0x05373da8, nsIPresShell * 0x05373ee0, nsIPresContext * 0x05650178, nsIContent * 
0x05646e50, nsIFrame * & 0x00000000) line 3705
StyleSetImpl::ConstructRootFrame(StyleSetImpl * const 0x0562a7f0, nsIPresContext 
* 0x05650178, nsIContent * 0x05646e50, nsIFrame * & 0x00000000) line 1397 + 39 
bytes
PresShell::InitialReflow(PresShell * const 0x05373ee0, int 15330, int 0) line 
2642
HTMLContentSink::StartLayout() line 3966
HTMLContentSink::DidBuildModel(HTMLContentSink * const 0x05620700, int 0) line 
2803
CNavDTD::DidBuildModel(CNavDTD * const 0x05296598, unsigned int 2152596471, int 
1, nsIParser * 0x056228e0, nsIContentSink * 0x05620700) line 669 + 14 bytes
nsParser::DidBuildModel(unsigned int 2152596471) line 1383 + 55 bytes
nsParser::Terminate() line 1468
nsHTMLDocument::StopDocumentLoad(nsHTMLDocument * const 0x051eea28) line 877
DocumentViewerImpl::Stop(DocumentViewerImpl * const 0x05661050) line 1349
nsDocShell::Stop(nsDocShell * const 0x054438c8, unsigned int 3) line 2301
nsDocShell::Destroy(nsDocShell * const 0x054438cc) line 2458
nsWebShell::Destroy(nsWebShell * const 0x054438cc) line 1424
nsHTMLFrameInnerFrame::~nsHTMLFrameInnerFrame() line 701
nsHTMLFrameInnerFrame::`scalar deleting destructor'(unsigned int 1) + 15 bytes
nsFrame::Destroy(nsFrame * const 0x0567b57c, nsIPresContext * 0x056087a8) line 
466 + 34 bytes
nsFrameList::DestroyFrames(nsIPresContext * 0x056087a8) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x0567b53c, nsIPresContext * 
0x056087a8) line 140
nsFrameList::DestroyFrames(nsIPresContext * 0x056087a8) line 131
nsContainerFrame::Destroy(nsContainerFrame * const 0x0567b3d8, nsIPresContext * 
0x056087a8) line 140
nsLineBox::DeleteLineList(nsIPresContext * 0x056087a8, nsLineList & {...}) line 
292
nsBlockFrame::Destroy(nsBlockFrame * const 0x0567b0c0, nsIPresContext * 
0x056087a8) line 327 + 16 bytes
nsFrameList::DestroyFrame(nsIPresContext * 0x056087a8, nsIFrame * 0x0567b0c0) 
line 217
CanvasFrame::RemoveFrame(CanvasFrame * const 0x0567aa48, nsIPresContext * 
0x056087a8, nsIPresShell & {...}, nsIAtom * 0x00000000, nsIFrame * 0x0567b0c0) 
line 370
FrameManager::RemoveFrame(FrameManager * const 0x0559dbf0, nsIPresContext * 
0x056087a8, nsIPresShell & {...}, nsIFrame * 0x0567aa48, nsIAtom * 0x00000000, 
nsIFrame * 0x0567b0c0) line 858
nsCSSFrameConstructor::ReconstructDocElementHierarchy(nsCSSFrameConstructor * 
const 0x053fad20, nsIPresContext * 0x056087a8) line 7139 + 61 bytes
StyleSetImpl::ReconstructDocElementHierarchy(StyleSetImpl * const 0x051b05e0, 
nsIPresContext * 0x056087a8) line 1404
PresShell::ReconstructFrames() line 5231 + 41 bytes
PresShell::StyleSheetAdded(PresShell * const 0x05621838, nsIDocument * 
0x05638048, nsIStyleSheet * 0x0525d958) line 5243
nsDocument::InsertStyleSheetAt(nsDocument * const 0x05638048, nsIStyleSheet * 
0x0525d958, int 0, int 1) line 1399
CSSLoaderImpl::InsertSheetInDoc(nsICSSStyleSheet * 0x0525d958, int 0, nsIContent 
* 0x05441c20, int 1, nsICSSLoaderObserver * 0x00000000) line 1177
CSSLoaderImpl::SheetComplete(nsICSSStyleSheet * 0x0525d958, SheetLoadData * 
0x052a1648) line 880
CSSLoaderImpl::ParseSheet(nsIUnicharInputStream * 0x053463c0, SheetLoadData * 
0x052a1648, int & 1, nsICSSStyleSheet * & 0x0525d958) line 935
CSSLoaderImpl::DidLoadStyle(nsIStreamLoader * 0x052a17c8, nsString * 0x04ad8d28, 
SheetLoadData * 0x052a1648, unsigned int 0) line 970 + 27 bytes
SheetLoadData::OnStreamComplete(SheetLoadData * const 0x052a1648, 
nsIStreamLoader * 0x052a17c8, nsISupports * 0x00000000, unsigned int 0, unsigned 
int 8897, const char * 0x05668488) line 727
nsStreamLoader::OnStopRequest(nsStreamLoader * const 0x052a17cc, nsIRequest * 
0x051c1e98, nsISupports * 0x00000000, unsigned int 0) line 137
nsStreamListenerTee::OnStopRequest(nsStreamListenerTee * const 0x05191ac0, 
nsIRequest * 0x051c1e98, nsISupports * 0x00000000, unsigned int 0) line 25
nsHttpChannel::OnStopRequest(nsHttpChannel * const 0x051c1e9c, nsIRequest * 
0x053d74a4, nsISupports * 0x00000000, unsigned int 0) line 2320
nsOnStopRequestEvent::HandleEvent() line 213
nsARequestObserverEvent::HandlePLEvent(PLEvent * 0x05198204) line 116
PL_HandleEvent(PLEvent * 0x05198204) line 590 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00f93080) line 520 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x002000ea, unsigned int 49385, unsigned int 0, 
long 16330880) line 1071 + 9 bytes
USER32! 77e02e98()
USER32! 77e030e0()
USER32! 77e05824()
nsAppShellService::Run(nsAppShellService * const 0x01043b30) line 303
main1(int 2, char * * 0x003527a8, nsISupports * 0x00000000) line 1269 + 32 bytes
main(int 2, char * * 0x003527a8) line 1599 + 37 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e87d08()
Assignee: asa → attinasi
Status: UNCONFIRMED → NEW
Component: Browser-General → Layout
Ever confirmed: true
QA Contact: doronr → petersen

Comment 6

16 years ago
wfm using build 2001120408 on Linux.
There're many other bug reports dealing with SqWebmail: bug 111741, bug 107213,
bug 107792. Might be dupe of bug 103997 then and of bug 52334 or bug 108105.
(Reporter)

Comment 7

16 years ago
Using 2001121003 on NT4 the https sqwebmail page opens (no crash anymore). Now
the CSS backround is missing, so maybe that was causing it? Ok, it's much
better, thanks.

Comment 8

16 years ago
Same problem, different link.  Clicking "Access Online Banking" from the
follwing link crashes Mozilla 0.97 on Mandrake 8.1.

http://www.servicecu.org/atyourservice.htm

It worked fine with Mozilla 0.96.

Comment 9

16 years ago
Kenton, I opened bug 118490 for your last comment.
Should we mark this bug WORKSFORME ? It works fine with Win2k and Linux with
2002010508.
Does not crash for me using 2002011803 build on WINNT.
Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Target Milestone: --- → mozilla1.2
You need to log in before you can comment on or make changes to this bug.