Content area inaccessible on Android

VERIFIED FIXED in Firefox 38

Status

()

Core
Disability Access APIs
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: maxli, Assigned: maxli)

Tracking

({regression})

38 Branch
mozilla38
All
Android
regression
Points:
---

Firefox Tracking Flags

(firefox38 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
On my Nexus 5 with Lollipop, and TalkBack 3.6, I can't explore by touch or swipe to get to the web content area.
(Assignee)

Comment 1

3 years ago
Seems to have occurred between the Jan 21 and 22 nightly builds.

Comment 2

3 years ago
(In reply to Max Li [:maxli] from comment #1)
> Seems to have occurred between the Jan 21 and 22 nightly builds.

That results in this regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=540077a30866&tochange=34e2d2bd7ec4

There were no accessibility patches at all landed in that period, so it has to do with something else in the Android codebase that changed.
Keywords: regression

Comment 3

3 years ago
The first bad revision is:
changeset:   224804:a2651cba8673
user:        Nick Alexander <nalexander@mozilla.com>
date:        Tue Jan 20 15:17:58 2015 -0800
summary:     Bug 1093358 - Add mobile/android AppConstants.jsm. r=mfinkle,f=rnewman

Nick, any idea why this might have broken TalkBack support?
Blocks: 1093358
Flags: needinfo?(nalexander)
(In reply to Marco Zehe (:MarcoZ) from comment #3)
> The first bad revision is:
> changeset:   224804:a2651cba8673
> user:        Nick Alexander <nalexander@mozilla.com>
> date:        Tue Jan 20 15:17:58 2015 -0800
> summary:     Bug 1093358 - Add mobile/android AppConstants.jsm.
> r=mfinkle,f=rnewman
> 
> Nick, any idea why this might have broken TalkBack support?

I made a mistake in that patch but it was fixed by Bug 1130812.  That ticket should have landed almost a week ago.  Can you verify that the issue is not in fact fixed by that bug?  If it is not fixed, can you give me steps to reproduce.

It is of course possible I made additional mistakes :/  Thanks so much for finding a regression range and hunting this down.
Flags: needinfo?(nalexander) → needinfo?(mzehe)
(Assignee)

Comment 5

3 years ago
It appears to have been a typo in the AppConstants.jsm file.
(Assignee)

Comment 6

3 years ago
Created attachment 8566152 [details] [diff] [review]
Patch
Assignee: nobody → maxli
Attachment #8566152 - Flags: review?(nalexander)
Comment on attachment 8566152 [details] [diff] [review]
Patch

Review of attachment 8566152 [details] [diff] [review]:
-----------------------------------------------------------------

You'll also need to fix my error at https://hg.mozilla.org/mozilla-central/annotate/9696d1c4b3ba/mobile/android/modules/moz.build#l37.

Thanks for catching my errors :/
Attachment #8566152 - Flags: review?(nalexander) → review+
(Assignee)

Comment 8

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/fbb2f8d1a841
https://hg.mozilla.org/mozilla-central/rev/fbb2f8d1a841
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox38: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
(Assignee)

Updated

3 years ago
Flags: needinfo?(mzehe)
Verified fixed in the 2015-02-19 nightly build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.