search results header on tablet shows two duplicate headers

RESOLVED FIXED

Status

Marketplace
Consumer Pages
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: ngoke, Assigned: ngoke)

Tracking

x86
Mac OS X
Points:
---

Details

(Assignee)

Description

3 years ago
STR:

1. Search on Marketplace
2. Resize to tablet width

Expected:

1 header

Actual:

2 headers. One says like "XXX has X results", one says "X results"

Also, the implementation is a bit messy as it uses some too-general "hide-on-desktop" and "hide-on-mobile" classes. For some reason, "hide-on-mobile" is "display:block" on mobile, then "display: block" on tablet, and "display: none !important;" on desktop.

These should be changed so there is a .search-results-header-mobile and .search-results-header-desktop, and it is styled within search.styl. We don't want to share classes between components.
(Assignee)

Updated

3 years ago
Blocks: 1103195
Assignee: nobody → dspasovski
Priority: -- → P3
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1135211
(Assignee)

Updated

3 years ago
Assignee: dspasovski → kngo
(Assignee)

Comment 2

3 years ago
https://github.com/mozilla/fireplace/commit/e220cf6056f555b17aafde01a027fda348bbc864
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.