Crash in LDAP E-mail completions and saving to IMAP Draft folder

VERIFIED DUPLICATE of bug 108922

Status

MailNews Core
LDAP Integration
--
critical
VERIFIED DUPLICATE of bug 108922
17 years ago
10 years ago

People

(Reporter: Jeff Pitman, Assigned: Srilatha Moturi)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112012

The steps below are assuming that one has Redhat Linux 7.2 with the mozilla
build listed above downloaded from prebuilt binaries found on www.mozilla.org. 
(Not RPM'ed).  Also you must have a viable LDAP server that can actively
retrieve names on the fly using email completion.  Potentially you may have to
use an IMAP email account.

By following the procedure below one will be able to make the entire Mozilla
suite come down to its knees and make a hard exit.  I tried searching for a
relavent core file but couldn't find jack.

This crash may have to do with memory leaks and stuff mentioned in other bugs. 
I feel that since this is quite severe another bug needs to be opened to address
the issue.

Reproducible: Always
Steps to Reproduce:
1. Create a new email (CTRL-M).
2. Add about 12-15 addresses to the TO: or CC: fields.  Preferrably using the
(+Addresses) Icon.
3. Go to the bottom of the list in the compose email window and add a new CC:
address.  This time, type it in and make sure its a name from LDAP.
4. Hit CTRL-S to save this in the Drafts folder of your favorite IMAP account.
5. *Boom*

Actual Results:  Major crash.  No core dump.  No talkback anything.

Expected Results:  Complete the typed Email from the set LDAP server and let me
save the message without losing about 30 minutes of writing an email. :-)
(Reporter)

Comment 1

17 years ago
I'm not a Mozilla developer, so I'm not sure where this goes.  But, I pulled up mozilla under ddd and ran my procedures and got the following backtrace.  Obviously I don't have full symbols on and no source code attached.  does it help??#0  0x00000000 in ?? ()#1  0x40fd6809 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#2  0x40ffd507 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#3  0x40150551 in XPTC_InvokeByIndex () from ./libxpcom.so#4  0x40929049 in NSGetModule () from /usr/local/mozilla/components/libxpconnect.so#5  0x4092eb4c in NSGetModule () from /usr/local/mozilla/components/libxpconnect.so#6  0x40067e72 in js_Invoke () from ./libmozjs.so#7  0x400680bc in js_InternalInvoke () from ./libmozjs.so#8  0x4007ace1 in js_GetProperty () from ./libmozjs.so#9  0x4006e6f6 in js_Interpret () from ./libmozjs.so#10 0x40067ec0 in js_Invoke () from ./libmozjs.so#11 0x400680bc in js_InternalInvoke () from ./libmozjs.so#12 0x4007ace1 in js_GetProperty () from ./libmozjs.so#13 0x4006e6f6 in js_Interpret () from ./libmozjs.so#14 0x40067ec0 in js_Invoke () from ./libmozjs.so#15 0x40924d5f in NSGetModule () from /usr/local/mozilla/components/libxpconnect.so#16 0x40921a51 in NSGetModule () from /usr/local/mozilla/components/libxpconnect.so#17 0x401506f4 in XPTC_InvokeByIndex () from ./libxpcom.so#18 0x401507ae in nsXPTCStubBase::Stub5 () from ./libxpcom.so#19 0x40150551 in XPTC_InvokeByIndex () from ./libxpcom.so#20 0x40929049 in NSGetModule () from /usr/local/mozilla/components/libxpconnect.so#21 0x4092ea05 in NSGetModule () from /usr/local/mozilla/components/libxpconnect.so#22 0x40067e72 in js_Invoke () from ./libmozjs.so#23 0x4006f907 in js_Interpret () from ./libmozjs.so#24 0x40067ec0 in js_Invoke () from ./libmozjs.so#25 0x400680bc in js_InternalInvoke () from ./libmozjs.so#26 0x4004a64b in JS_CallFunctionValue () from ./libmozjs.so#27 0x414f6375 in NSGetModule () from /usr/local/mozilla/components/libjsdom.so#28 0x4151e6db in NSGetModule () from /usr/local/mozilla/components/libjsdom.so#29 0x410f3d97 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#30 0x410f1692 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#31 0x410f1ee9 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#32 0x410f1f8a in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#33 0x40fbfd79 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#34 0x410b3ba9 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#35 0x4109cd5d in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#36 0x4109cd5d in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#37 0x4109cd5d in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#38 0x410a121f in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#39 0x414fa2e2 in NSGetModule () from /usr/local/mozilla/components/libjsdom.so#40 0x41111744 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#41 0x4112f969 in NSGetModule () from /usr/local/mozilla/components/libgkcontent.so#42 0x4165ab21 in NSGetModule () from /usr/local/mozilla/components/libgklayout.so#43 0x4165a9b1 in NSGetModule () from /usr/local/mozilla/components/libgklayout.so#44 0x41799309 in _fini () from /usr/local/mozilla/components/libgkview.so#45 0x417992af in _fini () from /usr/local/mozilla/components/libgkview.so#46 0x417992af in _fini () from /usr/local/mozilla/components/libgkview.so#47 0x417a2652 in _fini () from /usr/local/mozilla/components/libgkview.so#48 0x41798d2d in _fini () from /usr/local/mozilla/components/libgkview.so#49 0x408815ba in _fini () from /usr/local/mozilla/components/libwidget_gtk.so#50 0x408814e5 in _fini () from /usr/local/mozilla/components/libwidget_gtk.so#51 0x4087fb61 in _fini () from /usr/local/mozilla/components/libwidget_gtk.so#52 0x4087c09f in _fini () from /usr/local/mozilla/components/libwidget_gtk.so#53 0x4087c59f in _fini () from /usr/local/mozilla/components/libwidget_gtk.so#54 0x4087c304 in _fini () from /usr/local/mozilla/components/libwidget_gtk.so#55 0x40349d7f in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0#56 0x4037d773 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0#57 0x4037dd39 in g_main_iterate () from /usr/lib/libglib-1.2.so.0#58 0x4037deec in g_main_run () from /usr/lib/libglib-1.2.so.0#59 0x40298333 in gtk_main () from /usr/lib/libgtk-1.2.so.0#60 0x408764f4 in _fini () from /usr/local/mozilla/components/libwidget_gtk.so#61 0x4073d20e in fcGlueContext () from /usr/local/mozilla/components/libnsappshell.so#62 0x0804f640 in main1 ()#63 0x0804fea7 in main ()#64 0x404c4627 in __libc_start_main (main=0x804fd78 <main>, argc=1, ubp_av=0xbfffef54, init=0x804b4f0 <_init>, fini=0x8050c50 <_fini>, rtld_fini=0x4000dcd4 <_dl_fini>, stack_end=0xbfffef4c) at ../sysdeps/generic/libc-start.c:129
(Reporter)

Comment 2

17 years ago
I just replicated this on Win32 under two builds:

20011120
20011203 - nightly snapshot

I have been trying to send the talkbacks in, but talkback.netscape.com is 
broken right now.  When I get a chance over the next few days they will come in.

Couple more things:

1. Sorry for the stupid backtrack dump, I won't do that again. (attachments, 
duh!)
2. This bug probably does *not* have anything to do with LDAP, so you might 
want to reassign to GUI people or others.  Because I was able to reproduce the 
bug using Local Address completion.

Thanks for your help!  And sorry for the spam.
Reporter: Talkback IDs are very useful to the developers. So, when you can,
please post the Talkback ID here. 
(you can get the talkback id by running 'talkback' in
<moz-dir>/bin/components/talkback)

You may also wish to try a more recent build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-i686-pc-linux-gnu-sea.tar.gz
Keywords: crash, stackwanted
(Reporter)

Comment 4

17 years ago
K, for the 20011120 build checkout talkback incident #TB27679E

For the 20011203 build checkout talkback incident #TB28209Q

Something more, you do not have to save to the Drafts folder.  All you have to 
do is type a zillion names in the To: field and then scroll the list up and 
down.  And then *Boom* the window is gone.
CC: stephend@netscape.com, for talkback retrieval, please (TB28209Q)
Keywords: stackwanted
Stack Signature  0x036a9298 e576051d
Trigger Time 2001-12-04 04:52:48
Email Address bruthasj@yahoo.com
URL visited N/A
User Comments This dump is bug #113411 entered at bugzilla.mozilla.org. Thanks.
Build ID 2001120309
Product ID MozillaTrunk
Platform
Operating System Win32
Module
Trigger Reason Privileged instruction
Stack Trace
0x036a9298
nsHTMLInputElement::GetValue
[d:\builds\seamonkey\mozilla\content\html\content\src\nsHTMLInputElement.cpp,
line 431]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 154]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2011]
XPC_WN_GetterSetter
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1299]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
js_GetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2448]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2625]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
js_GetProperty [d:\builds\seamonkey\mozilla\js\src\jsobj.c, line 2448]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2625]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
nsXPCWrappedJSClass::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjsclass.cpp, line 1218]
nsXPCWrappedJS::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappedjs.cpp, line 430]
PrepareAndDispatch
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp,
line 117]
SharedStub
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcstubs.cpp,
line 139]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 154]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2011]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2792]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3407]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1012]
nsJSEventListener::HandleEvent
[d:\builds\seamonkey\mozilla\dom\src\events\nsJSEventListener.cpp, line 182]
nsEventListenerManager::HandleEventSubType
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1214]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
2206]
nsXULElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\xul\content\src\nsXULElement.cpp, line 3404]
PresShell::HandleDOMEventWithTarget
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5902]
nsMenuFrame::Execute
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 1602]
nsMenuFrame::HandleEvent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsMenuFrame.cpp, line 454]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5871]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5779]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 385]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 344]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 344]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 344]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1914]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 849]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 866]
nsWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4424]
ChildWindow::DispatchMouseEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4674]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3390]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1114]
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x30e0 (0x77e130e0)
USER32.DLL + 0x5824 (0x77e15824)
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 303]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1285]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1602]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1620]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 
Marking as dupe of bug 108922. Reporter: If you disagree, please reopen this bug.

*** This bug has been marked as a duplicate of 108922 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 8

17 years ago
Verified as dup
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.