Settings app does not fire moz-app-loaded or mark fullyLoaded

RESOLVED FIXED in 2.2 S7 (6mar)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Eli, Assigned: GaryChen)

Tracking

({perf})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
When running performance tests against the Settings app, the test times out as the app never fires the moz-app-loaded event, nor creates the marker of fullyLoaded, which are side-by-side in the code [1]. The triggering of these events appears to be indicated in the comments as being dependent on the loading of the telephony settings, which is then dependent on being idle. So at first glance, either the telephony settings aren't being loaded or it isn't idle by the time the test times out.

I tried running the test with a timeout of 120 seconds and it still timed out waiting for the performance event. It could just be that telephony settings isn't being loaded.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/js/main.js#L91
(Reporter)

Updated

4 years ago
Flags: needinfo?(ehung)
Flags: needinfo?(arthur.chen)
This was regressed by bug 1123164 in which we load `dsds_settings.js` by default in `main.js`. That made LazyLoader unable to count the correct number of loaded file and fail to call the callback.

We will avoid loading `dsds_settings.js` using LazyLoader again and make sure bug 1123164 still being fixed at the same time.
Assignee: nobody → jeroentulp
Flags: needinfo?(ehung)
Flags: needinfo?(arthur.chen)
Assignee: jeroentulp → nobody
Assignee: nobody → gchen
Posted file pr for master
Hi Arthur,
   Bug 1123164 doesn't exists, after removing 'dsds_settings.js' which was loaded by lazyloader. 
   So I think we can remove it for fixing this issue, could you help to take a look this patch?

   Thanks.
Attachment #8568464 - Flags: review?(arthur.chen)
blocking-b2g: --- → 2.2?
Comment on attachment 8568464 [details] [review]
pr for master

r=me, thank you!
Attachment #8568464 - Flags: review?(arthur.chen) → review+
https://github.com/mozilla-b2g/gaia/pull/28407

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8568464 [details] [review]
pr for master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1123164
[User impact] if declined: The description of each sim card item does not reflect the current state (ex: sim card not ready, no sim card ...etc)
[Testing completed]: Testing on the device
[Risk to taking this patch] (and alternatives if risky): None as the patch only removes a redundant loading.
[String changes made]: None
Attachment #8568464 - Flags: approval-gaia-v2.2?
Attachment #8568464 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
You need to log in before you can comment on or make changes to this bug.