Arabic and Georgian languages do not display correctly

RESOLVED FIXED

Status

()

Core
Internationalization
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Jay Farrell, Assigned: Colin Blake)

Tracking

Trunk
DEC
OpenVMS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; OpenVMS COMPAQ_AlphaStation_DS10_617_MH; en-US;
rv:0.9.6) Gecko/20011112
BuildID:    2001112014

This internationalization test is to confirm all that different language
appear correctly. Arabic and Georgian do not on OpenVMS using Mozilla rev 0.9.6.

Reproducible: Always
Steps to Reproduce:
1.install Mozilla 0/9/6 on OpenVMS
2.Go to http://www.unicode.org/iuc/iuc10/x-utf8.html 
3.see that Arabic and Georgian do not display

Actual Results:  see question marks displayed

Expected Results:  Expect to see valid caharcters displayed, not questions marks.
Jay, I assume you have the necessary fonts installed?

Comment 2

16 years ago
->smontagu
Assignee: yokoyama → smontagu
(Assignee)

Comment 3

16 years ago
OpenVMS bug. I'll take it.
Assignee: smontagu → colin
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
DECwindows for OpenVMS does NOT come with Arabic and Georgian fonts. So the 
correct answer is "this is a limitation in our DECwindows product".

I searched the web and found some X font files which supposedly contained both 
Arabic and Georgian fonts. I downloaded these and after playing around a while 
figured out how to "install" them on OpenVMS. After doing this, I could go to 
the smoketest page and see Arabic and Georgian text. If you want to give it a 
try, here's what I did.

go to http://www.cl.cam.ac.uk/~mgk25/ucs-fonts.html and download the 
"-misc-fixed-*" font package: 
http://www.cl.cam.ac.uk/~mgk25/download/ucs-fonts.tar.gz 

Unzip and untar the BDF (bitmap distribution font) files into a 
temporary directory somewhere: 

$ gzip -d UCS-FONTS_TAR.GZ 
$ tar -xvf UCS-FONTS_TAR. *.bdf 

Convert the BDF files into PCF font files that DECwindows understand: 

$ font 10X20.BDF 
$ font 4X6.BDF 
$ font 5X7.BDF 
$ font 5X8.BDF 
$ font 6X10.BDF 
$ font 6X12.BDF 
$ font 6X13.BDF 
$ font 6X13B.BDF 
$ font 6X13O.BDF 
$ font 6X9.BDF 
$ font 7X13.BDF 
$ font 7X13B.BDF 
$ font 7X13O.BDF 
$ font 7X14.BDF 
$ font 7X14B.BDF 
$ font 8X13.BDF 
$ font 8X13B.BDF 
$ font 8X13O.BDF 
$ font 9X15.BDF 
$ font 9X15B.BDF 
$ font 9X18.BDF 
$ font 9X18B.BDF 
$ font CLR6X12.BDF 
$ font HELVR12.BDF 

Decide where you want to "install" the new fonts to. I used 
SYS$COMMON:[SYSFONT.DECW.USER_COMMON]. Then copy the PCF files there and run 
FONT/DIR to create a new DECW$FONT_DIRECTORY.DAT file: 

$ copy /log *.pcf SYS$COMMON:[SYSFONT.DECW.USER_COMMON] 
$ font /dir SYS$COMMON:[SYSFONT.DECW.USER_COMMON] 

Log out of DECwindows and start a new DECwindows session. You should now have 
Arabic and Georgian fonts (thought I noticed not all size/weights of the Arabic 
font were present; this must be because they were not in the original BDF 
files). 

Colin. 

PS: gzip and tar are not standard VMS utilities. If you don't already have them, 
ask around (or I can send you images). 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
Jay Farrell, could you verify this since we do not have the right environment?
QA Contact: teruko → jfarrell
(Reporter)

Comment 6

16 years ago
Colin, I just assumed these would ship and install with the latest Rev 1.0 RC2,
but I still see the problem. (I have not attempted the download of those files)
Should these ship by default, or are they "download on demand"?
OpenVMS 20020513
(Assignee)

Comment 7

16 years ago
No, fonts are not a part of Mozilla. Font ship with the GUI, MOTIF (DECwindows) 
in this case, and MOTIF V1.2 on OpenVMS did not ship Arabic and Georgian 
fonts.

This is not a Mozilla problem. What part of my reply made you think that the 
fonts would ship with Mozilla?

For what its worth, I hear that the upcoming MOTIF 1.3 release on OpenVMS does 
ship with more fonts.
(Reporter)

Comment 8

16 years ago
my bad. I assumed that since this was "resolved fixed" that it meant that these 
files would/could be shipped with mozilla. After re-reading your entry, I see
your point. Sorry about that.
You need to log in before you can comment on or make changes to this bug.