[FTU] About Firefox OS page has "Yes! Send data." checked primarily.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::First Time Experience
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: PBylenga, Assigned: marshall_law)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [fromAutomation])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8566283 [details]
2015-02-18-18-21-07.png

Description:
During FTU, the checkbox to Send Data is initially checked on the About Firefox OS page.  This is causing automation to fail.


Repro Steps:
1) Update a Flame to 20150218010226
2) Start FTU
3) Navigate to "About Firefox OS" page and note the checkbox for sending data


Actual:
Checkbox is initially checked


Expected:
Checkbox is not initially checked

Environmental Variables:
Device: Flame 3.0 Nightly 319MB
Build ID: 20150218010226
Gaia: 82f286f10a41aab84a0796c89fbefe67b179994b
Gecko: 9696d1c4b3ba
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0



Repro frequency: (10/10, 100%)
See attached: screenshot
(Reporter)

Comment 1

3 years ago
[Blocking Requested - why for this release]:
Unexpected regression causing Automation to fail.

This issue does not reproduce on v2.2

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150218002515
Gaia: da509caa7395d3d090ce973e8de082b4680a590d
Gecko: 96da179a7d3a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Blocks: 1134257
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(ktucker)
Keywords: regression, regressionwindow-wanted
Whiteboard: [fromAutomation]
QA Whiteboard: [QAnalyst-Triage?]
QA Contact: pcheng
Flags: needinfo?(ktucker)
b2g-inbound regression window:

Last Working Environmental Variables:
Device: Flame
BuildID: 20150217113115
Gaia: 189d6b3c4e44cfd28a92ce7dee4e06739f479feb
Gecko: fb9680492d09
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame
BuildID: 20150217115909
Gaia: a8ab4a083908ed02950c76eea3c2ccb855b3a7d9
Gecko: 8f2b17571c09
Version: 38.0a1 (3.0 Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 189d6b3c4e44cfd28a92ce7dee4e06739f479feb
Gecko: 8f2b17571c09

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: a8ab4a083908ed02950c76eea3c2ccb855b3a7d9
Gecko: fb9680492d09

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/189d6b3c4e44cfd28a92ce7dee4e06739f479feb...a8ab4a083908ed02950c76eea3c2ccb855b3a7d9

Caused by the patch for Bug 1109422.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Marshall, can you take a look at this please? Looks like the landing for Bug 1109422 might have caused this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(marshall)
(Assignee)

Comment 4

3 years ago
Sharing performance / data usage has been changed to opt-in with Bug 1109422 (which is why "Yes" is initially checked now)
Flags: needinfo?(marshall)
(In reply to Marshall Culpepper [:marshall_law] from comment #4)
> Sharing performance / data usage has been changed to opt-in with Bug 1109422
> (which is why "Yes" is initially checked now)

Do you mean opt-out? Wilfred, can we confirm this is intended behavior? If so lets resolve this bug. As it is, unless users un-check the "Send data" box, they are opted-in for telemetry. Previously this was unchecked by default.
Flags: needinfo?(wmathanaraj)
(Assignee)

Comment 6

3 years ago
(In reply to Sam Foster [:sfoster] from comment #5)
> Do you mean opt-out? 

Yes, I meant opt-out.. apologies :)
The behavior has changed since yesterday in 2.2. It is now reproducible against:
Build ID               20150219002504
Gaia Revision          ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gaia Date              2015-02-19 05:02:26
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/159a3907b959
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150219.035309
Firmware Date          Thu Feb 19 03:53:21 EST 2015
Bootloader             L1TC000118D0
blocking-b2g: 3.0? → 2.2?
status-b2g-v2.2: unaffected → affected
(In reply to Marshall Culpepper [:marshall_law] from comment #4)
> Sharing performance / data usage has been changed to opt-in with Bug 1109422
> (which is why "Yes" is initially checked now)

Who made this decision?
Flags: needinfo?(marshall)
Either blocking or invalid.
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 10

3 years ago
This was surfaced up as a requirement to collect the right data for accurately calculating Monthly Active Users for FirefoxOS. Dominik have more details about the history of the product requirement..
Flags: needinfo?(marshall) → needinfo?(dstrohmeier)
The change to 'default on' data collection was made to enable measuring Monthly Active Users which is one of the FxOS key goals for 2015. Having the data collection default on is required to ensure that we collect a critical amount of data to do any valid and reliable calculations for MAUs later.

So yes, sharing performance / usage data by default is intended behavior and users will need to un-check the box to opt-out.
Flags: needinfo?(dstrohmeier)
I'm unclear who's authoritative here, but sounds like we should flip this to RESOLVED/INVALID?
Responsible Product Manager is Ravi Dandu.
Flags: needinfo?(rdandu)
We can close it if this feature got a proper privacy review and this is in line with https://www.mozilla.org/en-US/privacy/firefox/
Ravi, who did the privacy review?

Comment 16

3 years ago
Geoff Piper is doing the legal/privacy review. The legal/privacy bug is https://bugzilla.mozilla.org/show_bug.cgi?id=1109429.
Geoff, let us know if this current bug can be unblocked.
Flags: needinfo?(rdandu) → needinfo?(gpiper)
Clearing flag for Wilfred
Flags: needinfo?(wmathanaraj)

Comment 18

3 years ago
Hi Geoff, is there any update from your side? thanks.
Flags: needinfo?(gpiper)

Comment 19

3 years ago
I have drafted the privacy notice inclusions to address 2 new data points (1) app usage and (2) search default info.

but, what I need to see is the UI/UX for how we will allow a user to opt-out of these data collection points.

Ravi, would you organize a meeting on this topic so I can see a demo and understand how we are accomplishing this?

Comment 20

3 years ago
ni Ravi based on comment 19.
Flags: needinfo?(rdandu)
We worked with Geoff and got all issues resolved.
Geoff gave legal/privacy approval yesterday on bug https://bugzilla.mozilla.org/show_bug.cgi?id=1109429
Flags: needinfo?(rdandu)
Flags: needinfo?(gpiper)
(In reply to Dominik Strohmeier from comment #21)
> We worked with Geoff and got all issues resolved.
> Geoff gave legal/privacy approval yesterday on bug
> https://bugzilla.mozilla.org/show_bug.cgi?id=1109429

Can you add me to bug 1109429?

Comment 23

3 years ago
qawanted to verify this is fixed, if so, we can closed this one
Keywords: qawanted
Flags: needinfo?(nhirata.bugzilla)
It's there.  Are you qawanted, to make sure that the checkbox is there or if it's also taking metrics?
If it's the metrics part, we'll need to ask taipei to verify that portion.

The ui has it turned on for 2.2/3.0
Flags: needinfo?(hochang)

Comment 25

3 years ago
Right, the checkbox part. The legal/privacy is approved and default checked is the intended behavior, we should close this one then.
Flags: needinfo?(hochang)
Keywords: qawanted
Closing based on comment 25, and comment 2 / https://bugzilla.mozilla.org/show_bug.cgi?id=1109422#c32 / https://github.com/mozilla-b2g/gaia/commit/a8ab4a083908ed02950c76eea3c2ccb855b3a7d9
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → FIXED
Assignee: nobody → marshall
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Target Milestone: --- → 2.2 S7 (6mar)
Hi Edward, please check this on v2.2 as we still get error from gaia test, thanks.
Flags: needinfo?(edchen)
The script has some problem which is assertTrue statement in line 99. If you mark it, the result is PASS.
Flags: needinfo?(edchen)
Flags: needinfo?(ashiue)

Comment 29

3 years ago
Failed due to test case does not updated for the new change that checkbox to Send Data is initially checked. 
bug 1134257 tries to fix this problem.
Flags: needinfo?(ashiue)

Comment 30

3 years ago
Adding Marshall Erwin and Caitlin to this Bug. I believe this is UX and related work for the MAU (App Usage) project...and I believe certain decisions now are having us revisit defining the user benefit required as necessary for making such a collection default-on (opt-out). 

Caitlin and Marshall can provide more information on this aspect....which may or may not impact this Bug but I am just making sure this is known and a dependency to be resolved prior to its release.
Status: RESOLVED → REOPENED
Flags: needinfo?(cgalimidi)
Resolution: FIXED → ---
Geoff 

This is the device-side work that needs to be done to enable the collection of data on versions 2.2 and forward. We should not block this bug.

Let's have our discussion about the server-side requirements with the server-side team https://bugzilla.mozilla.org/show_bug.cgi?id=1129060
Flags: needinfo?(cgalimidi)

Comment 32

3 years ago
I understand. Noting, I believe the language has been changed from "Submit data" now to "Yes! Send data" 
right? I believe we need to be consistent and maybe the easiest path is to leave as-is "Submit data." 

If the UX copy changes even this minor, I believe this will have flow down effects (e.g., we would need to update/change the SUMO article image captures too and maybe other places too) right?
Geoff,
this bug talks about the FTU routine where the feature is called "Yes! Send data". Later, a user would search for that feature in Settings > Improve B2G OS. There, the feature is still called "Submit data". This is also the feature where the SUMO article is referring to. A regular user won't be able to re-access the FTU after setting up the device. The go-to point for the feature will also be the Settings menu.

Does this clarify things? Will this be sufficient?
Flags: needinfo?(gpiper)

Comment 34

3 years ago
I see...well for 3.0 I would like to revisit all of this and get them consistent especially we may well be renaming the "Submit data" anyway. So ok for now.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Flags: needinfo?(gpiper)
Based on comment 25, this issue is working as intended. I've verified on Flame 3.0 and 2.2 that during FTU the about firefox page has the 'yes! send data' option checked by default.

Device: Flame 2.2
BuildID: 20150612002504
Gaia: cfceba16e48ede3defee24be93637a0fa291c494
Gecko: 3478f3c355c2
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 3.0
BuildID: 20150612010203
Gaia: 9f36b711af7597a6a32471c3305cf1e2d6947d39
Gecko: 0093691d3715
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.