Closed Bug 1134545 Opened 5 years ago Closed 5 years ago

Crash [@ nsHTMLEditor::RelativeFontChange] with selection not in document

Categories

(Core :: DOM: Editor, defect, critical)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla39
Tracking Status
firefox36 - wontfix
firefox37 - wontfix
firefox38 + fixed
firefox39 + fixed

People

(Reporter: jruderman, Assigned: ayg)

References

(Blocks 1 open bug)

Details

(Keywords: crash, testcase)

Attachments

(3 files)

Attached file testcase
No description provided.
Attached patch PatchSplinter Review
Caused by bug 1086349 part 8, which made calling CanContainTag with a null argument fatal.  Previously it would just return false, which is correct here.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=2fd78e67637a
Assignee: nobody → ayg
Status: NEW → ASSIGNED
Attachment #8582393 - Flags: review?(ehsan)
Attachment #8582393 - Flags: review?(ehsan) → review+
[Tracking Requested - why for this release]:
This is a regression from bug 1086349 which landed in the 36 cycle.
Without any data on the prevalence of this crash, I find it hard to make an argument for taking a fix in the 37 RC. As such, I've marked 36 and 37 as wontfix. I have tracked 38+ as we should definitely take the crash fix in the next release.
(In reply to Lawrence Mandel [:lmandel] (use needinfo) from comment #4)
> Without any data on the prevalence of this crash, I find it hard to make an
> argument for taking a fix in the 37 RC. As such, I've marked 36 and 37 as
> wontfix. I have tracked 38+ as we should definitely take the crash fix in
> the next release.

Looks like crash-stats doesn't have this signature, so that's fine.
http://hg.mozilla.org/integration/mozilla-inbound/rev/e7688fa5ba48
Flags: in-testsuite+
OS: Mac OS X → All
Hardware: x86_64 → All
https://hg.mozilla.org/mozilla-central/rev/5abf1cce5ebe
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla39
Aryeh, can we have an uplift request to beta (38)? Thanks
Flags: needinfo?(ayg)
Comment on attachment 8582393 [details] [diff] [review]
Patch

Sorry for the delay, I was away from computers for a week.

Approval Request Comment
[Feature/regressing bug #]: Bug 1086349
[User impact if declined]: Crash under circumstances that seem unlikely to occur in the wild, bug was caught by fuzz-testing
[Describe test coverage new/current, TreeHerder]: Crashtest for the bug is checked in, general editor test coverage is fairly decent for a large subset of real-world cases
[Risks and why]: Very low risk, just adds a null check
[String/UUID change made/needed]: None
Flags: needinfo?(ayg)
Attachment #8582393 - Flags: approval-mozilla-beta?
Comment on attachment 8582393 [details] [diff] [review]
Patch

Thanks. Should be in 38 beta 4.
Attachment #8582393 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.