Crash on second run (never on first) in CyanogenMod 5.0.1

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: asdofindia, Unassigned)

Tracking

36 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150126171358

Steps to reproduce:

Happens in both version 35 stable and version fennec-36.0b8.en-US.android-arm.apk

Install the app
Run it happily
Switch to another app 
Come back to Firefox, continue browsing happily.
Swipe close the Firefox app in recent apps
Try starting firefox again.. Crash..
Restart the phone
Start Firefox.. Crash..
Settings->apps->firefox->Clear data
Launch firefox. 
Runs happily, and the cycle continues from beginning.


Actual results:

D/lights  (  473): write_int open fd=-1
W/AudioTrack(  473): AUDIO_OUTPUT_FLAG_FAST denied by client
I/Timeline(  901): Timeline: Activity_launch_request id:org.mozilla.firefox_beta time:698437
I/ActivityManager(  473): START u0 {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.firefox_beta/.App bnds=[372,674][460,782] (has extras)} from uid 10014 on display 0
E/AudioTrack(  473): AudioTrack::set : Exit
D/MtkAudioLoud(  136): +SetWorkMode()
D/MtkAudioLoud(  136): -SetWorkMode()
D/MtkAudioLoud(  136): +Open()
D/AudioResourceManager(  136): TurnonAudioDevice = 0x2 DeviceCount = 1
D/AudioPlatformDevice(  136): AudioPlatformDevice AnalogOpen DeviceType = DEVICE_OUT_SPEAKERR 
D/AudioPlatformDevice(  136): AudioPlatformDevice AnalogOpen DeviceType = DEVICE_OUT_EARPIECER 
D/AudioMachineDevice(  136): AudioMachineDevice AnalogOpen DeviceType = DEVICE_OUT_SPEAKERR
I/ActivityManager(  473): Start proc org.mozilla.firefox_beta for activity org.mozilla.firefox_beta/.App: pid=3848 uid=10137 gids={50137, 9997, 3003, 1028, 1015} abi=armeabi-v7a
D/GeckoSharedPrefs( 3848): Current version = 1, prefs version = 1
D/GeckoScreenOrientation( 3848): updating to new orientation PORTRAIT_PRIMARY
D/GeckoLoader( 3848): Gecko environment env0: null
E/GeckoLibLoad( 3848): Load sqlite start
W/GeckoLinker( 3848): /data/app/org.mozilla.firefox_beta-1/base.apk!/assets/armeabi-v7a/libnss3.so: unhandled flags #8 not handled
E/GeckoLibLoad( 3848): Load sqlite done
E/GeckoLibLoad( 3848): Load nss start
E/GeckoLibLoad( 3848): Load nss done
W/GeckoLinker( 3848): /data/app/org.mozilla.firefox_beta-1/base.apk!/assets/armeabi-v7a/libxul.so: unhandled flags #8 not handled
W/GeckoLinker( 3848): /data/app/org.mozilla.firefox_beta-1/base.apk!/assets/armeabi-v7a/libmozalloc.so: unhandled flags #8 not handled
F/libc    ( 3848): Fatal signal 4 (SIGILL), code 1, fault addr 0xb6ef8ab8 in tid 3870 (Thread-331)
I/DEBUG   (  133): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
I/DEBUG   (  133): Build fingerprint: '4.4.4/KPW53/1379542:user/release-keys'
I/DEBUG   (  133): Revision: '0'
I/DEBUG   (  133): ABI: 'arm'
I/DEBUG   (  133): pid: 3848, tid: 3870, name: Thread-331  >>> org.mozilla.firefox_beta <<<
I/DEBUG   (  133): signal 4 (SIGILL), code 1 (ILL_ILLOPC), fault addr 0xb6ef8ab8
I/DEBUG   (  133):     r0 9fa098f4  r1 00000020  r2 00000000  r3 9fa09904
I/DEBUG   (  133):     r4 00000000  r5 ad276020  r6 b8c2af10  r7 9fa098f4
I/DEBUG   (  133):     r8 b8c2aab0  r9 9fa098fc  sl 00000001  fp 9fa09904
I/DEBUG   (  133):     ip 00000001  sp 9fa098e8  lr b6ef6ed7  pc b6ef8ab8  cpsr 200f0030
I/DEBUG   (  133): 
I/DEBUG   (  133): backtrace:
I/DEBUG   (  133):     #00 pc 00000ab8  /system/lib/libc.so
I/DEBUG   (  133):     #01 pc 00012ed3  /system/lib/libc.so (timer_create+170)
I/DEBUG   (  133):     #02 pc 0006d8cc  /system/lib/libMali.so
I/DEBUG   (  133):     #03 pc 00066d5c  /system/lib/libMali.so
I/DEBUG   (  133):     #04 pc 00067bf8  /system/lib/libMali.so (_mali_base_common_context_create+248)
I/DEBUG   (  133):     #05 pc 0005d8a0  /system/lib/libMali.so
I/DEBUG   (  133):     #06 pc 0005c180  /system/lib/libMali.so
I/DEBUG   (  133):     #07 pc 0005cd28  /system/lib/libMali.so (shim_eglInitialize+64)
I/DEBUG   (  133):     #08 pc 0000f8a1  /system/lib/libEGL.so (android::egl_display_t::initialize(int*, int*)+120)
I/DEBUG   (  133):     #09 pc 00010b73  /system/lib/libEGL.so (eglInitialize+62)
I/DEBUG   (  133):     #10 pc 0005c367  /system/lib/libandroid_runtime.so
I/DEBUG   (  133):     #11 pc 0085f703  /data/dalvik-cache/arm/system@framework@boot.oat
D/StatusBar.MSimNetworkController(  595): getPhoneId phoneId: 0
D/StatusBar.MSimNetworkController(  595): getPhoneId phoneId: 0
D/StatusBar.MSimNetworkController(  595): updateIconSet, phoneId = 0
D/StatusBar.MSimNetworkController(  595): updateIconSet, voice network type is: 10/HSPA, data network type is: 10/HSPA
D/StatusBar.MSimNetworkController(  595): updateIconSet, chosenNetworkType=10 hspaDataDistinguishable=true hspapDistinguishable=false showAtLeastThreeGees=false
D/StatusBar.MSimNetworkController(  595): getPhoneId phoneId: 0
D/StatusBar.MSimNetworkController(  595): updateTelephonySignalStrength: phoneId =0
D/StatusBar.MSimNetworkController(  595): getPhoneId phoneId: 0
D/StatusBar.MSimNetworkController(  595): refreshViews phoneId =0mMSimDataConnected =true
D/StatusBar.MSimNetworkController(  595): refreshViews mMSimDataActivity =0
W/ActivityManager(  473):   Force finishing activity org.mozilla.firefox_beta/.App
I/DEBUG   (  133): 
I/DEBUG   (  133): Tombstone written to: /data/tombstones/tombstone_05
I/BootReceiver(  473): Copying /data/tombstones/tombstone_05 to DropBox (SYSTEM_TOMBSTONE)
E/SharedPreferencesImpl(  473): Couldn't create directory for SharedPreferences file shared_prefs/log_files.xml
I/Zygote  (  145): Process 3848 exited due to signal (4)
I/WindowManager(  473): Screenshot max retries 4 of Token{1f7a0099 ActivityRecord{12b755e0 u0 org.mozilla.firefox_beta/.App t1428 f}} appWin=Window{b6bf00c u0 Starting org.mozilla.firefox_beta} drawState=4
E/ActivityManager(  473): Invalid thumbnail dimensions: 288x288
W/ActivityManager(  473): Exception thrown during pause
W/ActivityManager(  473): android.os.DeadObjectException
W/ActivityManager(  473): 	at android.os.BinderProxy.transactNative(Native Method)
W/ActivityManager(  473): 	at android.os.BinderProxy.transact(Binder.java:496)
W/ActivityManager(  473): 	at android.app.ApplicationThreadProxy.schedulePauseActivity(ApplicationThreadNative.java:701)
W/ActivityManager(  473): 	at com.android.server.am.ActivityStack.startPausingLocked(ActivityStack.java:853)
W/ActivityManager(  473): 	at com.android.server.am.ActivityStack.finishActivityLocked(ActivityStack.java:2783)
W/ActivityManager(  473): 	at com.android.server.am.ActivityStack.finishTopRunningActivityLocked(ActivityStack.java:2640)
W/ActivityManager(  473): 	at com.android.server.am.ActivityStackSupervisor.finishTopRunningActivityLocked(ActivityStackSupervisor.java:2460)
W/ActivityManager(  473): 	at com.android.server.am.ActivityManagerService.handleAppCrashLocked(ActivityManagerService.java:11624)
W/ActivityManager(  473): 	at com.android.server.am.ActivityManagerService.makeAppCrashingLocked(ActivityManagerService.java:11521)
W/ActivityManager(  473): 	at com.android.server.am.ActivityManagerService.crashApplication(ActivityManagerService.java:12200)
W/ActivityManager(  473): 	at com.android.server.am.ActivityManagerService.handleApplicationCrashInner(ActivityManagerService.java:11716)
W/ActivityManager(  473): 	at com.android.server.am.NativeCrashListener$NativeCrashReporter.run(NativeCrashListener.java:86)
E/lowmemorykiller(  117): Error opening /proc/3848/oom_score_adj; errno=2
I/ActivityManager(  473): Process org.mozilla.firefox_beta (pid 3848) has died
E/WindowState(  473): getStack: Window{b6bf00c u0 Starting org.mozilla.firefox_beta} couldn't find taskId=1428 Callers=com.android.server.wm.WindowState.getDisplayContent:760 com.android.server.wm.WindowState.getWindowList:1323 com.android.server.wm.WindowManagerService.removeWindowInnerLocked:2745 com.android.server.wm.WindowManagerService.removeWindowLocked:2646 
E/WindowState(  473): getStack: Window{b6bf00c u0 Starting org.mozilla.firefox_beta} couldn't find taskId=1428 Callers=com.android.server.wm.WindowState.getDisplayContent:760 com.android.server.wm.WindowManagerService.removeWindowInnerLocked:2750 com.android.server.wm.WindowManagerService.removeWindowLocked:2646 com.android.server.wm.WindowManagerService.removeWindow:2568 
W/art     (  473): Long monitor contention event with owner method=void com.android.server.am.ActivityManagerService.crashApplication(com.android.server.am.ProcessRecord, android.app.ApplicationErrorReport$CrashInfo) from ActivityManagerService.java:12151 waiters=1 for 354ms
W/art     (  473): Long monitor contention event with owner method=void com.android.server.am.ActivityManagerService.crashApplication(com.android.server.am.ProcessRecord, android.app.ApplicationErrorReport$CrashInfo) from ActivityManagerService.java:12151 waiters=2 for 244ms
I/MaliEGL (  901): [Mali]window_type=1, is_framebuffer=0, errnum = 0
I/MaliEGL (  901): [Mali]surface->num_buffers=4, surface->num_frames=3, win_min_undequeued=1
I/MaliEGL (  901): [Mali]max_allowed_dequeued_buffers=3
I/OpenGLRenderer(  473): Initialized EGL, version 1.4
I/Timeline(  901): Timeline: Activity_idle id: android.os.BinderProxy@21faf52f time:699875
E/        (  473): appName=system_server, acAppName=/system/bin/surfaceflinger
E/        (  473): 0
I/MaliEGL (  473): [Mali]window_type=1, is_framebuffer=0, errnum = 0
I/MaliEGL (  473): [Mali]surface->num_buffers=4, surface->num_frames=3, win_min_undequeued=1
I/MaliEGL (  473): [Mali]max_allowed_dequeued_buffers=3
I/Timeline(  473): Timeline: Activity_windows_visible id: ActivityRecord{3be85a2f u0 com.cyanogenmod.trebuchet/com.android.launcher3.Launcher t1426} time:700131
W/OpenGLRenderer(  901): Incorrectly called buildLayer on View: ShortcutAndWidgetContainer, destroying layer...
E/        (  136): AudioCloseDumpPCMFile file== NULL
E/        (  136): AudioCloseDumpPCMFile file== NULL
E/        (  136): AudioCloseDumpPCMFile file== NULL
E/        (  136): AudioCloseDumpPCMFile file== NULL
D/AudioResourceManager(  136): TurnoffAudioDevice = 0x2 DeviceCount = 1
D/AudioMachineDevice(  136): AnalogClose DeviceType = DEVICE_OUT_SPEAKERR
D/AudioPlatformDevice(  136): AudioPlatformDevice AnalogClose DeviceType = DEVICE_OUT_SPEAKERR
D/AudioPlatformDevice(  136): AudioPlatformDevice AnalogClose DeviceType = DEVICE_OUT_EARPIECER
D/MtkAudioLoud(  136): +ResetBuffer()
D/MtkAudioLoud(  136): -ResetBuffer()
D/AudioMTKStreamOut(  136): -AudioMTKStreamOut standby
^C



Expected results:

Shouldn't crash.
Additionally, I'm running CyanogenMod 5.0.1 on an MTK device (Android One, Micromax Canvas A1) with no Google Play services. The download was directly taken from the FTP servers.
(Reporter)

Updated

4 years ago
OS: Linux → Android
Hardware: x86_64 → ARM
Do you get this crash running on stable Cyanogenmod?
Flags: needinfo?(asdofindia)

Comment 2

4 years ago
I get the same issue when running Firefox on CyanogenMod11 on Geeksphone Revolution.
I don't have have the Google Play services neither.

Firefox 37.0 downloaded from FDroid.
CyanogenMod: 11-20150408-UNOFFICIAL-revolution
Android: 4.4.4

Comment 3

4 years ago
Unable to replicate the bug for:

-Firefox 37.0.2 and fennec-40.0a1.multi.android-arm.apk
-CyanogenMod : 11.0-XNPH05Q
-Phone - OnePLus One - Android 4.4.4
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX

Comment 4

4 years ago
Bug reproduced:
-Firefox 37.0.2
-CyanogenMod: 11-20150408-UNOFFICIAL-revolution
-Phone - Geeksphone Revolution - Android: 4.4.4
-No google services

The bug is not reproduced after installation of google services.
I understand you leave it in WONTFIX but please test it in real conditions or don't test it (it's a waste of time).

Thanks anyway
(Reporter)

Comment 5

4 years ago
I updated to a stable (and greater version) cyanogenmod (version 5.1.1) without play store and I can't reproduce this issue anymore.
Flags: needinfo?(asdofindia)
You need to log in before you can comment on or make changes to this bug.