Saving attachments via Drag & Drop results in incorrect files

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: General
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: Sven C. Berger, Unassigned)

Tracking

SeaMonkey 2.32 Branch
x86_64
Windows 8.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0 SeaMonkey/2.32.1
Build ID: 20150204202218

Steps to reproduce:

1. Opened e-mail in Inbox with an attachment (PDF file of 350 kb size)
2. Drag & drop the attachment from SeaMonkey to desktop (Windows 8.1), i. e. c:\Users\Xyz\Desktop



Actual results:

File saved with correct filename, but only 43 bytes size.

Content (total):

'¼z│ZrΓr^₧╫▒╡7óù½u½ƒwδjíz╗º╡ΩαzV¥en==


Expected results:

File should have been saved with correct filename, correct content and size of 350kb.

Comment 1

3 years ago
So does the same happen with any/all attachments or only that one particular "pdf".

If you try to open the attachment directly (I suppose that's something you can do) does that work correctly?

If you save the attachment (instead of drag & drop) does it save correctly?

Comment 2

3 years ago
Wonder if the attachment was not yEnc encoded?
I'm thinking Thunderbird/Mail does not support yEnc?

Are you able to save the source of the file?

If you look at the file source in a file viewer, does it start with "=ybegin"?
(Reporter)

Comment 3

3 years ago
Thanks for your quick reply! Here are the answers:

> So does the same happen with any/all attachments or only that one particular "pdf".

It does happen with all kind of attachments (PDF, DOC, RTF...) and with several dozen e-mails tested.

> If you try to open the attachment directly (I suppose that's something you can do) does that work correctly?

Sometimes! PDF (with SumatraPDF) or DOC (with LibreOffice Writer) sometimes open correctly, but in some cases I get an error message (e. g. SumatraPDF: "Error loading XYZ.PDF"

> If you save the attachment (instead of drag & drop) does it save correctly?

Yes.

> Wonder if the attachment was not yEnc encoded? I'm thinking Thunderbird/Mail does not support yEnc?

No, it is not yEnc encoded, it's base64 in an an MIME message (Content-Type: multipart/alternative).

> Are you able to save the source of the file?

Yes.

> If you look at the file source in a file viewer, does it start with "=ybegin"?

No. The respective part of the message starts as follows:

--b1_ee0913e400c06176a641015d22e6de32
Content-Type: application/octet-stream; name="XYZ.pdf"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="XYZ.pdf"
(Reporter)

Comment 4

2 years ago
I cannot reproduce this problem with the most recent release anymore - great!

User-Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0 SeaMonkey/2.38
Build-Identifikator: 20150923195647
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.