We should log the location of the extracted firefox binary when running

RESOLVED FIXED

Status

Testing
mozregression
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

I recently used mozregression to diagnose an issue with e10s and talos:

https://bugzilla.mozilla.org/show_bug.cgi?id=1134238#c4

Unfortunately the talos process was hanging so I couldn't really use the "execute a script to determine success / failure". Instead, I just pointed talos against the extracted executable and ran/killed it manually, then inputed the result to mozregression. To do this, I needed to print out the name of the executable that we were running (e.g. '/tmp/tmpMIe1rp/firefox/firefox'), since I otherwise had no way of getting it.

We could probably get more ambitious and have a mode for mozregression where we don't even try to launch the browser, but I think just logging the location is probably good enough for the few occasions where you'd want to do this.
Created attachment 8566765 [details] [review]
Log the location of the executable we're launching
Attachment #8566765 - Flags: review?(j.parkouss)
Comment on attachment 8566765 [details] [review]
Log the location of the executable we're launching

Looks good to me!

The travis build failed for other reasons - I fixed the style errors first (there was a flake8 update it seems, that catches more things).

I merged this in. :)
Attachment #8566765 - Flags: review?(j.parkouss) → review+
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.