[Settings] Hitting the up or down volume rocker on the phone will erase already entered text on the Passcode screens for the Screen Lock section of settings.

VERIFIED FIXED in Firefox OS v2.2

Status

VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: arthurcc)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8566803 [details]
logcat_20150219_1355.txt

Summary (title) Field:
[Settings] Hitting the up or down volume rocker on the phone will erase already entered text on the Passcode screens for the Screen Lock section of settings.

Description:
When creating or changing a passcode in the Screen Lock section of Settings, if you tap up or down on the volume rocker bar, text will be removed from the text fields.

Notes: Up or Down on the volume both erase text at a 1 press: 1 digit erased ratio. Volume is still adjusted up or down as expected.
Does not occur on Lockscreen Passcode entry. 

Repro Steps:
1) Update a Flame to 20150219010228
2) Launch Settings > Screen Lock
3) Toggle Passcode Lock on
4) Enter 4 or 5 digits
5) Hit the volume up or down rocker


Actual:
Up and Down volume rocker will erase text

Expected:
Volume Rocker will have no effect on text entry

Environmental Variables:
Device: Flame 3.0
Build ID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 9/9
See attached: logcat, video: http://youtu.be/M4WJt-1OmUI
(Reporter)

Comment 1

4 years ago
This issue also reproduces on 2.2

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-------------------------------------------------------------------------------
This issue does NOT reproduce on 2.1

Device: Flame 2.1 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150219001626
Gaia: a43e3cdf8783e9d87156d47b8bfff0f5f44f9e2e
Gecko: 5653f229724f
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Was asked to nom for 2.2? blocking.  Having said this, I think I would backlog this as polish.  The main reasons why:

1) Not sure how many people will hit the volume button when on the settings -> lockscreen.
2) It only occurs on the settings -> lockscreen, not on the lock screen when it's up.
3) The other point is that the visual shows that it backspaced and verifying the code confirms that it was a backspace/deletion and not an extraneous entry.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
NI developer for investigating this.
Flags: needinfo?(gchang) → needinfo?(arthur.chen)
Created attachment 8568981 [details] [review]
[gaia] crh0716:1134860 > mozilla-b2g:master
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
Comment on attachment 8568981 [details] [review]
[gaia] crh0716:1134860 > mozilla-b2g:master

EJ, could you help review this patch?

Rudy, please help check if the proposed patch makes sense to you.

Thanks!
Attachment #8568981 - Flags: review?(ejchen)
Attachment #8568981 - Flags: feedback?(rlu)
Comment on attachment 8568981 [details] [review]
[gaia] crh0716:1134860 > mozilla-b2g:master

This approach looks good to me.
Thanks.
Attachment #8568981 - Flags: feedback?(rlu) → feedback+

Updated

4 years ago
blocking-b2g: 2.2? → 2.2+
Comment on attachment 8568981 [details] [review]
[gaia] crh0716:1134860 > mozilla-b2g:master

This becomes a 2.2 blocker. Evelyn, could you help review this simple patch when you get a chance? Thanks.
Attachment #8568981 - Flags: review?(ejchen) → review?(ehung)

Updated

4 years ago
Attachment #8568981 - Flags: review?(ehung) → review+
Thanks, Evelyn!

master: 06df45a3ca38193a6ff75c78291b1b307627e718
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
status-b2g-master: affected → fixed
Comment on attachment 8568981 [details] [review]
[gaia] crh0716:1134860 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: It seems bad user experience.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low. The patch just filters out events coming from the volume buttons.
[String changes made]: None.
Attachment #8568981 - Flags: approval-gaia-v2.2?

Updated

4 years ago
Attachment #8568981 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/5e94f84389fae7e0b9d256bd779be76bce704b33
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S7 (6mar)
This issue is verified fixed for the latest Nightly 3.0 and 2.2 builds.

Actual Results: Changing the volume while setting a passcode lock does not clear the entered numbers.
	
Environmental Variables:
Device: Flame 3.0 KK (319 MB) (Full Flash)
BuildID: 20150304010324
Gaia: 3fc0ac309f5fb0c1fe82c12223b955a4efce27e6
Gecko: c5b90c003be8
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319 MB) (Full Flash)
BuildID: 20150304002529
Gaia: 8b4b3e4b7e7c308764f71542437fd60625ac6b75
Gecko: 2cb52b7cda5a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.