Use fallible allocation in ChunkSet::Set()

RESOLVED DUPLICATE of bug 1134858

Status

()

Toolkit
Safe Browsing
RESOLVED DUPLICATE of bug 1134858
3 years ago
3 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
A number of people in #developers are reporting that they seem to be crashing when they get a safe browsing update.  This is happening in ChunkSet::Set which is calling InsertElementSorted.  Note that the desired allocation size is absurdly large (2208301052), so there is probably some underlying issue here.

https://crash-stats.mozilla.com/report/index/e69d15e6-ccde-4df3-8e3b-891cc2150219
https://crash-stats.mozilla.com/report/index/bcc3e726-349e-45b0-becb-efd212150219
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134858
(Reporter)

Comment 2

3 years ago
I guess I'll just dupe it over.  If whatever underlying problem wasn't happening, fallible allocation is probably not important.
I filed bug 1134885 before seeing this. Wouldn't want to have a SafeBrowsing update from another list provider "accidentally" disable all Firefoxes out there, would we.
You need to log in before you can comment on or make changes to this bug.