mdimporter plugin is missing its MacOS folder since version 36

RESOLVED FIXED in Thunderbird 39.0

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Nomis101, Assigned: jsbruner)

Tracking

36 Branch
Thunderbird 39.0
x86
macOS

Thunderbird Tracking Flags

(thunderbird37 fixed, thunderbird38+ fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

The mdimporter plugin Thunderbird.app/Contents/Library/Spotlight/thunderbird.mdimporter should contain a folder /Contents/MacOS. But the folder MacOS is missing since version 36, TB 34 still contains this folder (don't know for 35).
Posted patch Add back thunderbird-mdimporter. (obsolete) β€” β€” Splinter Review
Assignee: nobody → josiah
Status: NEW → ASSIGNED
Attachment #8574181 - Flags: review?(Pidgeot18)
Opps, when I made the Contents/Library directory more specific, I left out the Spotlight/ dir.
Attachment #8574181 - Attachment is obsolete: true
Attachment #8574181 - Flags: review?(Pidgeot18)
Attachment #8574189 - Flags: review?(Pidgeot18)
Comment on attachment 8574189 [details] [diff] [review]
Add back thunderbird-mdimporter.

Review of attachment 8574189 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me. Beyond the change to moz.build, I'm not sure of the importance of the changes in this patch, so I will trust your judgement that they are needed and/or desirable to fixing the bug.
Attachment #8574189 - Flags: review?(Pidgeot18) → review+
https://hg.mozilla.org/comm-central/rev/95064b70132a
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 39.0
Comment on attachment 8574189 [details] [diff] [review]
Add back thunderbird-mdimporter.

[Approval Request Comment]
Regression caused by (bug #): OS X Code Signing V2
User impact if declined: Users may not be able to open newly downloaded builds of TB if Gatekeeper is set to the default settings.
Testing completed (on c-c, etc.): On c-c.
Risk to taking this patch (and alternatives if risky): Low risk. Apparently mdimporter hasn't even had a binary since TB 35, so simply adding one back won't do much regression-wise.
Attachment #8574189 - Flags: approval-comm-beta?
Attachment #8574189 - Flags: approval-comm-aurora?
No longer blocks: 1083907
Duplicate of this bug: 1083907
Comment on attachment 8574189 [details] [diff] [review]
Add back thunderbird-mdimporter.

Pushed:

https://hg.mozilla.org/releases/comm-aurora/rev/136e574bccc5
https://hg.mozilla.org/releases/comm-beta/rev/2b629bdb2ba3
Attachment #8574189 - Flags: approval-comm-beta?
Attachment #8574189 - Flags: approval-comm-beta+
Attachment #8574189 - Flags: approval-comm-aurora?
Attachment #8574189 - Flags: approval-comm-aurora+
You need to log in before you can comment on or make changes to this bug.