Closed Bug 1134911 Opened 5 years ago Closed 5 years ago

[Settings] SIM dependant settings menus are accessible when there is no SIM card in the device.

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S8 (20mar)
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: Marty, Assigned: arthurcc)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing])

Attachments

(2 files)

Description:
The user is able to navigate into SIM Manager, Call Settings, Messaging Settings, and Cellular & Data menus when they do not have a SIM in the device.  Some elements of the sub-menus are greyed-out and not operable, but other elements are still accessible:
-SIM Manager settings (Outgoing Calls, Outgoing Messages, Data) have fields that display '--' and can be highlighted, but do not function.
-Messaging Settings can change the Delivery and Read Reports, Auto Retrieve, and WAP Push settings.
-Cellular & Data can toggle Data Connection and Data Roaming on and off.


Repro Steps:
1) Update a Flame to 20150219010228
2) Ensure there is not a SIM card in the device.
3) Launch the Settings app.
4) Open the SIM Manager, Call Settings, Messaging Settings, and Cellular & Data menus.

Actual:
Sim dependant settings menus are accessible without a SIM card.

Expected:
SIM dependant settings menus are not accessible without a SIM card.

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: logcat, video (URL)
This issue DOES occur in Flame 2.2.
Sim dependant settings menus are accessible without a SIM card.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------------------------------

This issue does NOT occur in Flame 2.1 builds.
SIM dependant settings menus are not accessible without a SIM card. These menu options are greyed-out.

Environmental Variables:
Device: Flame 2.1 (319MB)(Full Flash)
Build ID: 20150210002200
Gaia: 7dd130a312f12c89b2d41948f8557effa56afbf6
Gecko: 2de03dfa9aac
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Functional regression of settings app.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
QA Contact: ychung
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 2.2
BuildID: 20141119170406
Gaia: 8e09627d75acd4abced0ab81983b5b5de6d15881
Gecko: 65e88009c0b7
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First Broken Environmental Variables:
Device: Flame 2.2
BuildID: 20141119190306
Gaia: 3bc50f192966e653cbf99e3ac2e3c799945e996d
Gecko: 9b5ec4beb012
Version: 36.0a1 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 8e09627d75acd4abced0ab81983b5b5de6d15881
Gecko: 9b5ec4beb012

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: 3bc50f192966e653cbf99e3ac2e3c799945e996d
Gecko: 65e88009c0b7

https://github.com/mozilla-b2g/gaia/compare/8e09627d75acd4abced0ab81983b5b5de6d15881...3bc50f192966e653cbf99e3ac2e3c799945e996d

caused by bug 1092104
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Contact: ychung
Arthur, can you take a look at this please? Looks like the work done on bug 1092104 might have caused this to occur.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(arthur.chen)
The patch for bug 1092104 makes the first level items always enabled to enhance the UX. We should further define the state of each item in the second level menu when sim cards are not available. Some case are worth discussing like messaging settings and data connection settings as they are actually settings of RIL instead of sim card or operator. Flagging Jenny for her inputs.
Flags: needinfo?(arthur.chen) → needinfo?(jelee)
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → arthur.chen
Hi Martin and Arthur,

Please see below for my comments:

-SIM Manager settings (Outgoing Calls, Outgoing Messages, Data) have fields that display '--' and can be highlighted, but do not function.
=> This is the part that needs fixing. If there's no SIM card, the entire SIM settings section should not be shown at all; if there's only one SIM card, value selector should still be tappable and show only one option in the option menu.

-Messaging Settings can change the Delivery and Read Reports, Auto Retrieve, and WAP Push settings.
=> The options that are still available when there's no SIM card are basically just on and off switches, so it doesn't really matter if there's SIM card or not. Allowing user to make changes when there's no SIM card provides more flexibility, and it also gives better look and feel as this way, the entire panel won't be grayed out.  

-Cellular & Data can toggle Data Connection and Data Roaming on and off.
=> This design decision is made as the same reason mentioned above.

Thanks =)!
Flags: needinfo?(jelee)
Status: NEW → ASSIGNED
Comment on attachment 8574497 [details] [review]
[gaia] crh0716:1134911 > mozilla-b2g:master

Based on comment 6, the patch hides the sim settings section when there are no available sim cards. Could you help check the patch? Thanks.
Attachment #8574497 - Flags: review?(ejchen)
(In reply to Jenny Lee from comment #6)
> Hi Martin and Arthur,
> 
> Please see below for my comments:
> 
> -SIM Manager settings (Outgoing Calls, Outgoing Messages, Data) have fields
> that display '--' and can be highlighted, but do not function.
> => This is the part that needs fixing. If there's no SIM card, the entire
> SIM settings section should not be shown at all; if there's only one SIM
> card, value selector should still be tappable and show only one option in
> the option menu.

Jenny, if users are under airplane mode, should we still hide the whole section or not ? I remembered for some devices, "APM is on" means there is no SIM card inserted, while there are some devices would let us get the information. This difference would affect whether users can access SIM security or not, so is there any design for this scenario ? 

or let's just hide the whole block directly ? (This is the most straight-forward way by the way)
Flags: needinfo?(jelee)
Hi Ej,

Not sure if there's device that doesn't see airplane mode as no SIM card? 
For the device that sees airplane mode as no SIM card, we hide the section. Thanks =)!
Flags: needinfo?(jelee)
Comment on attachment 8574497 [details] [review]
[gaia] crh0716:1134911 > mozilla-b2g:master

Thanks Arthur, r+++ ! :)
Attachment #8574497 - Flags: review?(ejchen) → review+
Thanks EJ!

master: 41b1c5ce328c940843ac41489b0c2a76dc07b5d7
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Comment on attachment 8574497 [details] [review]
[gaia] crh0716:1134911 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): N/A
[User impact] if declined: Users are able to change sim related items even there is no sim card available, which seems odd. With the patch we hide the entire section for sim setting if there is no sim cards.
[Testing completed]: Testing on the device.
[Risk to taking this patch] (and alternatives if risky): Low. the patch simplifies the checking logic
[String changes made]: None
Attachment #8574497 - Flags: approval-gaia-v2.2?
Attachment #8574497 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 build.

Actual Results: The user is not shown the sim manager options when there is no SIM inserted into the device or Airplane mode is on.  Per comment 6, no other menus were changes as those are expected.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150317073344
Gaia: 738987bd80b0ddb4ccf853855388c2627e19dcc1
Gecko: 008b3f65a7e0
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (Full Flash) (319 MB)
BuildID: 20150316002502
Gaia: a6b2d3f8478ec250beb49950fecbb8a16465ff6f
Gecko: 18619f8f6c5c
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.