[Search] lines between history are off screen and makes the screen scrollable

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Search
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: YeojinC, Assigned: Nefzaoui)

Tracking

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5?, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8566881 [details]
logcat_20150219_SearchScreenOff.txt

Description:
When there are multiple items under HISTORY on the search result screen, the divider lines are shifted off the screen to the right. This makes the search screen horizontally scrollable to the right.

Repro Steps:
1) Update a Flame to 20150219010228
2) Enable Wi-Fi or data connection, and navigate to different websites to generate browser history. There has to be enough pages, so the search results displays more than 1 item under HISTORY.
3) Tap the search bar, and enter 1 or 2 letters to bring browser history under HISTORY.

Actual:
The dividers are shifted off the screen, and the screen can be scrolled to the right.

Expected:
The dividers are not shifted, and the search screen is NOT scrollable.

Environmental Variables:
Device: Flame 3.0 (KK, 319mb, full flash)
Build ID: 20150219010228
Gaia: 620aecfde85a8b093247837c55de2708e22be1e1
Gecko: 360b5f211180
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
See attached: logcat, video
http://youtu.be/WXt3H3OD0Po
(Reporter)

Comment 1

3 years ago
This issue does NOT reproduces on Flame 2.2.

Result: The search result screen is not scrollable.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This is a regression so nominating 3.0? Let's get a regression window.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
QA Contact: ychung
[Blocking Requested - why for this release]:
blocking-b2g: --- → 3.0?
(Reporter)

Comment 4

3 years ago
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame 3.0
BuildID: 20150218070906
Gaia: 6875a6ac9bcfacc5a7d97fc7a6839105dfeeb9e2
Gecko: b66abf148c10
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First Broken Environmental Variables:
Device: Flame 3.0
BuildID: 20150218074758
Gaia: db44e23e519094bf3db9b733f8f632689fdb20d1
Gecko: 3f5e549ddee9
Version: 38.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Last Working Gaia First Broken Gecko: Issue does NOT reproduce 
Gaia: 6875a6ac9bcfacc5a7d97fc7a6839105dfeeb9e2
Gecko: 3f5e549ddee9

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: db44e23e519094bf3db9b733f8f632689fdb20d1
Gecko: b66abf148c10

https://github.com/mozilla-b2g/gaia/compare/6875a6ac9bcfacc5a7d97fc7a6839105dfeeb9e2...db44e23e519094bf3db9b733f8f632689fdb20d1

caused by bug 1129701
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
(Reporter)

Updated

3 years ago
QA Contact: ychung
Blocks: 1129701
Bug 1129701 is now uplifted and it should break 2.2 as well. Can we test 2.2 again?
(Reporter)

Comment 6

3 years ago
(In reply to Gregor Wagner [:gwagner] from comment #5)
> Bug 1129701 is now uplifted and it should break 2.2 as well. Can we test 2.2
> again?

Yes, it is now affected in 2.2 as well.

Result: The dividers are shifted off the screen, and the screen can be scrolled to the right.

Device: Flame 2.2 (KK, 319mb, full flash)
Build ID: 20150220002501
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: b864abe1c6b3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
status-b2g-v2.2: unaffected → affected
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regression
Ahmed, can you take a look at this please? Looks like the landing and recent uplift for Bug 1129701 might have caused this to occur.
Flags: needinfo?(nefzaoui)
Fixed by backing out bug 1129701.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-b2g-v2.2: affected → fixed
status-b2g-master: affected → fixed
Flags: needinfo?(nefzaoui)
Resolution: --- → FIXED
This issue is verified fixed on the latest Nightly 3.0 and 2.2 builds
	
Actual results:  The bars between search terms are positioned correctly.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150226010233
Gaia: 7894b929f1b0394f3c997f72a6482bc7813e758d
Gecko: dd6353d61993
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150226002503
Gaia: bf24aa57fa7760260ab05d1f53242c8d8ae59e83
Gecko: 363123044e61
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Assignee: nobody → nefzaoui
Target Milestone: --- → 2.2 S7 (6mar)
You need to log in before you can comment on or make changes to this bug.