Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Save "open locations" and restore after crash

VERIFIED DUPLICATE of bug 36810

Status

SeaMonkey
General
--
enhancement
VERIFIED DUPLICATE of bug 36810
16 years ago
13 years ago

People

(Reporter: Mark Shuttleworth, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Quoting from The Register's review of Opera 6:

"The second of my two favourite Opera features is the ability to save your
position, and to restart from the interruption point if the app or the machine
crashes. If I've got 20-30 pages open, which is by no means unusual, then I'm
going to be a deeply sad bunny if they all just vanish with a thud. This can
happen with IE, and it can happen with monotonous regularity when Win2k decides
not to suspend properly, but with Opera you can just carry on from where you
were before. And you can keep a big pile of research material open all of the
time, for weeks or months if you like, through crashes and shutdowns. This is
such a killer feature I can't understand why Microsoft hasn't stolen it yet."

This does sound like a fantastic feature. Mozilla is amazingly stable nowadays,
more so than IE, but it does still tend to wipeout masses of windows when it
goes down. Tabbed browsing means we use even more "content windows" at any given
time. It would be great if a journal was kept of what was open, and if an
attempt was made to restore those images when Mozilla is restarted after a
crash. Of course this won't work with sites where the page is stateful, but most
static content would be fine.

Comment 1

16 years ago
Dupe of probably both 36810 and 19454.  Picking one...

*** This bug has been marked as a duplicate of 36810 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.