if recent file doesn't open (due to rename), window should not close

VERIFIED DUPLICATE of bug 102538

Status

SeaMonkey
Composer
--
major
VERIFIED DUPLICATE of bug 102538
16 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Charles Manske)

Tracking

Trunk
mozilla0.9.9

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
found using 2001.11.30.0x-comm bits on linux rh7.2, winnt and mac 10.1.1.

0. make sure you have previously edited a file in composer --let's say it's
called foo.html. confirm that this file appears in the editor submenu, File >
Recent Pages.
1. rename the file, eg, 'mv foo.html blah.html'.
2. bring up an empty editor window.
3. select File > Recent Pages > foo.html [yes, the old name is still listed
there, which i imagine is expected].
4. you get an alert [expected], saying that the file cannot be found.
5. dismiss the alert dlg.

expected: you should be returned to the editor window.

actual results: the editor window goes away!
(Reporter)

Comment 1

16 years ago
->cmanske? punt as needed!
Assignee: syd → cmanske
Keywords: mozilla0.9.8

Comment 2

16 years ago
is this a duplicate bug?  I thought I filed something a while back...
(shortening summary to fit; hope no one minds)
Summary: if a recent file cannot be opened (renamed), the composer window should not be dismissed → if recent file doesn't open (due to rename), window should not close
(Assignee)

Comment 3

16 years ago
This issue came up as part of the fix to handle the NS_ERROR_FILE_NOT_FOUND
condition. That bug was fixed and I suggested, but failed to figure out how to
reset the URL to "about:blank" when a file isn't found. My question to you was how 
can we change the URI on an existing channel. We can't start another load request
while in the "nsEditorShell::EndPageLoad" callback loop of editor.
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 102538 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.