When using the HTML <base> element SVG <use>-xlink:href doesn't find document-local elements in defs or symbols anymore

VERIFIED DUPLICATE of bug 1121708

Status

()

VERIFIED DUPLICATE of bug 1121708
4 years ago
4 years ago

People

(Reporter: commander, Unassigned)

Tracking

35 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150125221831

Steps to reproduce:

I used an svg in an html document containing <defs> and <use> elements. The <use> elements href attribute referenced local ids in the <defs>. I had a <base> element in <head>.

Note: works in Chromium/Chrome

With <base> (broken):
http://graphicore.de/downloads/svg_dfs_bug/bad-defs.html

Without <base> (good):
http://graphicore.de/downloads/svg_dfs_bug/good-defs.html


Actual results:

The referenced elements did not display.
Removing <base> solved the problem.


Expected results:

The referenced elements should display.
Chrome is broken, it shouldn't work because a UA should take <base> into account.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1121708
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.