Follow up bug 1132215 - Implement a CI test which check that the clear button works on the Contact's detail page

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Contacts
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jlorenzo, Assigned: Adrián de la Rosa)

Tracking

unspecified
2.2 S7 (6mar)
x86_64
Linux

Firefox Tracking Flags

(b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment)

Let's implement a test with this kind of checks:
> phoneNumberInput.sendKeys("123");
> clearButton.tap();
> assert.strictEqual(phoneNumberInput.text(), '')

Updated

3 years ago
Assignee: nobody → hola
Created attachment 8567967 [details] [review]
[gaia] ADLR-es:clear-btn-test > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
Comment on attachment 8567967 [details] [review]
[gaia] ADLR-es:clear-btn-test > mozilla-b2g:master

Test added that checks clear button for main fields.
Attachment #8567967 - Flags: review?(jmcf)

Comment 3

3 years ago
Comment on attachment 8567967 [details] [review]
[gaia] ADLR-es:clear-btn-test > mozilla-b2g:master

good work, but please fix the nit I have left on GH

thanks!
Attachment #8567967 - Flags: review?(jmcf) → review+
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
Pull request has landed in master: https://github.com/mozilla-b2g/gaia/commit/024134d719127257a6e5a73b6fe86ff2d15657c2

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S7 (6mar)
(Assignee)

Comment 5

3 years ago
Comment on attachment 8567967 [details] [review]
[gaia] ADLR-es:clear-btn-test > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): RTL
[User impact] if declined: Build process for RTL versions would be less robust since in this patch we add tests for a feature first broken by a RTL patch.
[Testing completed]: Yes.
[Risk to taking this patch] (and alternatives if risky): Low, just tests. We would risk to repeat bug 1132215 since it would not be automatically tested if not approved.
[String changes made]: None.
Attachment #8567967 - Flags: approval-gaia-v2.2?
status-b2g-v2.2: --- → affected

Updated

3 years ago
Attachment #8567967 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/3c4231f0935a3f8beb1e9a30a70334f5ac5e0b5d
status-b2g-v2.2: affected → fixed
You need to log in before you can comment on or make changes to this bug.