Firefox consistently crashing in dl_relocate_object

RESOLVED INVALID

Status

()

Firefox
Untriaged
--
critical
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Doug E, Unassigned)

Tracking

({crash})

35 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [crash caused by GarminPlugin, npGarminPlugin.so])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8567144 [details]
firefox_gdb_output.txt

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/40.0.2214.111 Safari/537.36

Steps to reproduce:

Firefox consistently crashes (SIGSEV issued) upon start on my Fedora 21 notebook.  Disabling plugins and hardware acceleration did not resolve the problem.   


Actual results:

A SIGSEV issued and application dies.   A copy of the gdb output from running < firefox -g > is attached showing the SIGSEV signal being issued by the application in the _dl_relocate_object function.   


Expected results:

Firefox project home page should be displayed in browser window.  The same version of Firefox is stable on my Fedora 21 desktop with a similar setup (OS, software packages, etc)
Talked to reporter in-person at SCALE, I'm not sure what's wrong here - anyonw know what's up?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

3 years ago
Any update?!  Problem still exists, even with newer versions of Firefox installed.

Comment 3

3 years ago
(In reply to Tanner Filip [:tanner] from comment #1)
> Talked to reporter in-person at SCALE, I'm not sure what's wrong here -
> anyonw know what's up?
Severity: normal → critical
Keywords: crash
As far as I can tell from the stack, we're loading a plugin and that plugin has
a dynamic link dependency to libXt.so so we try to load that and crash.
I don't know why _dl_relocate_object would crash on processing libXt.so, but
perhaps the one we found is for a different architecture? but I see no reason
for it to crash rather than just stop loading it and returning a failure code.
It's a bug in _dl_relocate_object IMO.

Anyway, he can probably locate which plugin is causing it by moving them out
of plugins directory(ies) (we search multiple places on Linux IIRC) one by
one and then see when the crashing stops.
Doug, were you able to track the plugin causing the problem?
Flags: needinfo?(dpephd-fedora)
(Reporter)

Comment 6

3 years ago
Mats, et al - 

Thank you for the assistance in debugging this problem.   I was able to figure out which plugin (GarminPlugin, npGarminPlugin.so, http://www.andreas-diesner.de/garminplugin/) was causing firefox to crash, apparently because of a problem in the _dl_relocate_object method. 

I did this manually by first removing all plugins from the /usr/lib64/mozilla/plugins and /usr/lib64/mozilla/plugins-wrapped directories and re-adding them one at a time and testing the stability of firefox after each addition.

The only other plugins I have running are the IcedTea-Web Plugin (IcedTea-Web 1.5.2 (fedora-0.fc21-x86_64)) and NPAPI Plugins Wrapper 1.4.4 (npwrapper.so).

I would note that running firefox in "safe mode" via firefox -safe-mode did not stop firefox from crashing with all the plugins present.  From the documentation, I would think that no plugins would be loaded when running in safe mode.

Thanks again for your assistance.  I do not absolutely need the GarminPlugin to run to upload Garmin GPS information to the websites I use, but it would be nice to have.  

Doug
Flags: needinfo?(dpephd-fedora)
Thank you for taking the time to track that down!  Please report the problem
to the author of the plugin.

>I would note that running firefox in "safe mode" via firefox -safe-mode did not stop firefox from >crashing with all the plugins present.  From the documentation, I would think that no plugins would be >loaded when running in safe mode.

Yes, I agree, this is a known bug: bug 342333.

Resolving as "invalid" since it's not a bug in Firefox.

Thanks for your report!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Whiteboard: [crash caused by GarminPlugin, npGarminPlugin.so]
You need to log in before you can comment on or make changes to this bug.