Closed Bug 1135107 Opened 6 years ago Closed 6 years ago

Implement per-test prefs

Categories

(Testing :: web-platform-tests, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox40 fixed)

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: jgraham, Assigned: jgraham)

References

Details

To enable in-development features for specific test cases we need a more finegrained way to enable prefs for specific tests. The most obvious solution is to put the pref in the .ini file for the test and set it in a precondition, then unset it in a postcondition, for the test. This won't work for prefs that require a restart ofc.
Duplicate of this bug: 1135106
https://hg.mozilla.org/mozilla-central/rev/6664c9e9fbc7
https://hg.mozilla.org/mozilla-central/rev/506cbf1944f2
https://hg.mozilla.org/mozilla-central/rev/f69f796181bc
Assignee: nobody → james
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.