Closed Bug 1135127 Opened 5 years ago Closed 5 years ago

The devtools window closes when I press enter in the URL bar to start a page load.

Categories

(DevTools :: General, defect, major)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1068400

People

(Reporter: mayhemer, Unassigned)

References

(Blocks 1 open bug)

Details

Current m-c.

Persistent logging is on, the web dev window closes when either it's open inline or a separate window.

This actually ruins the web dev window purpose.
STR (clean profile + Enable persistent logs):
- new window
- open webdev (F12)
- enter an address to the URL bar
- press enter
- webdev tools show ok
- new tab in the same window
- close the first tab => webdev tools close automatically (something also pretty unexpected for me when open as a new window!)
- switch to the new tab
- paste the same address as before to the URL bar
- press F12 => webdev tools open again as a new window
- Alt-Tab to the browser window (and Alf-D if needed to focus the address bar)
- press enter => webdev tools window is gone!
Example URL: http://gizmodo.uol.com.br/
I can't reproduce this. The detached toolbox closes when you close the tab because it's specific to that tab and can't be repurposed. But when I switch between windows and reload existing tabs everything works fine.

Do you see any errors in the Browser Console (Ctrl-Shift-J) when the toolbox closes unexpectedly?
The STR is very precise.  Are you on the current Nightly?
I am on the latest Nightly, but I don't see the devtools window disappearing in the last step. Would it be possible to post a screencast where you reproduce the problem, to see if I am doing something wrong?
Panos, forget STR from comment 1.

Here are new ones:
- current Nightly
- fresh profile, NO PREFERENCE CHANGES
- open a new tab, close all the welcome tabs
- type (paste) http://gizmodo.uol.com.br/ to the address bar
- press F12 (embedded devtools open)
- focus the address bar
- press enter
=> devtools window closes

Expected: it stays open.
Thanks, I can see it now with the new STR. It appears to be e10s-related, but I haven't figured out anything more.
Blocks: dte10s
Ah, turns out this is already known.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1068400
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.