[RTL] [FTE] Date/Time 'Change' button labels are clipped

VERIFIED FIXED in 2.2 S9 (3apr)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: sfoster, Assigned: mikehenrty)

Tracking

unspecified
2.2 S9 (3apr)
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Is fallout from bug 1130231? Anyhow, the button labels on the Date & Time screen are clipped in a RTL locale. The buttons are a fixed width and/or the wrong padding is applied
(Reporter)

Comment 1

4 years ago
screenshot of the issue in Mirrored English pseudo-locale
blocking-b2g: --- → 2.2?
blocking-b2g: 2.2? → 2.2+
I'll grab this one.
Assignee: nobody → mhenretty

Updated

4 years ago
Status: NEW → ASSIGNED
Depends on: 1140645
I think this has uncovered another platform bug in bug 1140645. Let's wait for the fix there before landing any workarounds here.

Updated

4 years ago
Depends on: 1010675
(In reply to Michael Henretty [:mhenretty] from comment #3)
> I think this has uncovered another platform bug in bug 1140645. Let's wait
> for the fix there before landing any workarounds here.

Bug 1010675 has been resolved, and I have asked developer to uplift to v2.2.
Can we verify this is fixed on latest m-c/master build given https://bugzilla.mozilla.org/show_bug.cgi?id=1010675 has landed?
Flags: needinfo?(pmathur)
Keywords: verifyme
Looking better to me :)
(In reply to Hermes Cheng[:hermescheng] from comment #4)
> Bug 1010675 has been resolved, and I have asked developer to uplift to v2.2.

Thank you Hermes! Marking dupe of bug 1010675 since this landing fixed this on master for me. Leaving the verifyme keyword since we should have someone from QA verify.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1010675
Verified fixed on master. 

Steps to Reproduce
1. Go to Settings > Language and select an RTL language from the selector (e.g. Arabic).
2. Go to Settings > Developer and tap on the Launch First Time Use button.
3. In the FTU wizard, tap on the Next button repeatedly till you come to the Date & Time screen.

Expected Results
The button labels are not clipped in a RTL locale. The UI is not broken in any way.

Actual Results
Matches the expected results. (see screenshot attached 1135161-ftu-timezone-arabic.png)

Test Environment
Gaia-Rev        9b6f3024e4d0e62dd057231f4b14abe1782932ab
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/e730012260a4
Build-ID        20150323010204
Version         39.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150323.043710
FW-Date         Mon Mar 23 04:37:21 EDT 2015
Bootloader      L1TC000118D0


Leaving the 'verifyme' keyword on to verify when it lands on b2g v2.2.
Status: RESOLVED → VERIFIED
Flags: needinfo?(pmathur)
Resolution: DUPLICATE → FIXED
Target Milestone: --- → 2.2 S9 (3apr)
According to the steps in Comment8, this issue is verified pass on latest flame 2.2 build.
See attachment:Verify_Flame2.2_Pass.png
Reproducing rate:0/5

Flame 2.2 build (Unaffected):
Build ID               20150327162502
Gaia Revision          473cd63f53c855299b719285d9b95e3f2910782f
Gaia Date              2015-03-27 20:14:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/b358619def45
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150327.194944
Firmware Date          Fri Mar 27 19:49:53 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [rtl-impact][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.