[RTL][Notifications] Review transfer request notifications have vertically overlapping text when in Arabic but receiving a transfer from a English named bluetooth device.

VERIFIED FIXED in 2.2 S8 (20mar)

Status

defect
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jmitchell, Assigned: apastor)

Tracking

unspecified
2.2 S8 (20mar)
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Description:
When in an RTL language (Arabic) and receiving a bluetooth transfer request from a device with an English-named bluetooth signal, the notification will have text that overlaps vertically. Basically the descenders from the English named device will overlap with the ascenders of the Arabic bluetooth message. A bluetooth name with multiple descenders will look worse.

Repro Steps:
1) Update a Flame to 20150220010206
2) Pair with another device with an English Bluetooth name (preferably with descenders) 
3) Recieve a bluetooth transfer request from the other device

Actual:
overlapping text in the notification

Expected:
no overlapping text

Environmental Variables:
Device: Flame 3.0
Build ID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 6/6
See attached: screenshot
(Reporter)

Comment 1

4 years ago
This issue also occurs in 2.2

Device: Flame 2.2 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150220002501
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: b864abe1c6b3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(pbylenga)
Overlapping text.
blocking-b2g: --- → 2.2+

Comment 3

4 years ago
Overlapping text is a blocker to RTL ship and violates the pattern. Blocking.
Is this system or BT component?
Flags: needinfo?(mhenretty)
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(pbylenga)
Adding P1 for triage purposes
Priority: -- → P1
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][systemsfe]
Taking.
Assignee: nobody → mhenretty
Flags: needinfo?(mhenretty)

Updated

4 years ago
Status: NEW → ASSIGNED
This is a blocker but hasn't been worked on yet. Michael: just a gentle reminder to look into this. ni on you as a reminder. Thanks :)
Flags: needinfo?(mhenretty)
Thanks for the reminder Delphine, I have been working on some other things.

Alberto, could you give me a hand on this one?
Flags: needinfo?(mhenretty) → needinfo?(apastor)
(Assignee)

Updated

4 years ago
Assignee: mhenretty → apastor
Flags: needinfo?(apastor)
(Assignee)

Updated

4 years ago
Attachment #8574689 - Flags: review?(mhenretty)
Test case has been added in moztrap:
https://moztrap.mozilla.org/manage/case/15671/
Flags: in-moztrap+
Comment on attachment 8574689 [details] [review]
[gaia] albertopq:1135195-rtl-notifications-bt > mozilla-b2g:master

Thanks!
Attachment #8574689 - Flags: review?(mhenretty) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Autolander could not locate a review from a user within the suggested reviewer list. Either the patch author or the reviewer should be in the suggested reviewer list.
(Assignee)

Comment 14

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/ca91e1b103a127e991217230f0b3d6083e8a2b87
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Please request Gaia v2.2 approval on this patch when you get a chance.
Flags: needinfo?(apastor)
Target Milestone: --- → 2.2 S8 (20mar)
This issue is verified fixed on the latest Nightly Flame 3.0 build.

Actual Results: The device name and message text do not overlap.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150312010235
Gaia: 0c4e8b0b330757e261b031b7e7f326ef419c9808
Gecko: 5334d2bead3e
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage?][rtl-impact]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?][rtl-impact] → [QAnalyst-Triage+][rtl-impact]
Flags: needinfo?(ktucker)
(Assignee)

Comment 17

4 years ago
Comment on attachment 8574689 [details] [review]
[gaia] albertopq:1135195-rtl-notifications-bt > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: The bluetooth request notification text overlaps.
[Testing completed]: Manual testing
[Risk to taking this patch] (and alternatives if risky): CSS only change
[String changes made]: none
Flags: needinfo?(apastor)
Attachment #8574689 - Flags: approval-gaia-v2.2?(bbajaj)
Attachment #8574689 - Flags: approval-gaia-v2.2?(bbajaj) → approval-gaia-v2.2+
According to the steps in comment 0, the issue has been verified pass on latest Flame 2.2 build.
See attachment:Verify2_Flame2.2_Pass.png
Reproducing rate:0/10

Flame 2.2 build:
Build ID               20150407162504
Gaia Revision          ea735c21bfb0d78333213ff0376fce1eac89ead6
Gaia Date              2015-04-07 20:58:15
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3f86ddb7f719
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150407.195227
Firmware Date          Tue Apr  7 19:52:39 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+][rtl-impact] → [QAnalyst-Triage+][rtl-impact][MGSEI-Triage+]
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.