[Rocketbar] Scrolling a highlighted search bar/URL can result in splintering the URL by it's refresh/draw rate

RESOLVED DUPLICATE of bug 1134504

Status

RESOLVED DUPLICATE of bug 1134504
4 years ago
4 years ago

People

(Reporter: onelson, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8567270 [details]
2015-02-20-15-13-18.png

Description:
When a user has typed in a large text field or hyperlink URL so that it may be scrolled within the rocketbar, highlighting the text then panning through with a swipe will reveal graphical faults. The 'highlight box' that encompasses the link will splinter while being scrolled, at a width that appears equivelent to the speed that the draw refreshes. This only occurs when the user pans the link towards the right to reveal the end of the link (swipe left); the opposite behavior has expected behavior.

Repro Steps:
1) Update a Flame to 20150220010206
2) Tap the Rocketbar "Search or enter address."
3) Type a bunch of characters (may also navigate to any website, particular a URL longer than www.google.com).
4) Hold tap in the address bar and highlight the text.
5) Swipe right (to reveal lefthand of text) to observe expected behavior on highlight draw.
6) Swipe left (to reveal righthand of text) to observe splintering on highlight draw.

Actual:
URL/Search bar splinters/fractures along it's draw, revealing gaps in between blocks of highlighted text.

Expected:
URL/Search bar remains solid and displays entirety of text that is highlighted.

Environmental Variables:
--------------------------------------------------
Device: Flame 3.0
Build ID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Device: Flame 2.2
BuildID: 20150220002501
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: b864abe1c6b3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
--------------------------------------------------

--------------------------------------------------
Issue DOES NOT occur on 2.1 for flame devices, does not support Cut-Copy-Paste
Device: Flame 2.1
BuildID: 20150220001208
Gaia: 373df4bec2c20228f45be0b24111252171f925e9
Gecko: 10c100cba54d
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-------------------------------------------------

Repro frequency: 5/5
See attached: 
video- http://youtu.be/CGB-rpUxMxU
screenshot
logcat
(Reporter)

Comment 1

4 years ago
Created attachment 8567271 [details]
logcat_20150220_1212.txt
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Whiteboard: [3.0-Daily-Testing]
NI for component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
I can also recreate this issue on other input fields, ex: subject field in email app.
Blocks: 1023688
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Text Selection]
Flags: needinfo?(gchang)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1134504
You need to log in before you can comment on or make changes to this bug.