Various GMP tests are going to permafail when Gecko 38 merges to Beta

VERIFIED FIXED in Firefox 37

Status

()

Toolkit
Add-ons Manager
--
critical
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: spohl)

Tracking

Trunk
mozilla38
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox37+ verified, firefox38+ verified)

Details

Attachments

(3 attachments)

(Reporter)

Description

3 years ago
Created attachment 8567307 [details]
xpcshell failure log

[Tracking Requested - why for this release]: Test permafail when Gecko 38 merges to Beta.

Rumor has it that bug 1089867 is wanted for Fx37 too, so requesting tracking there as well.

https://treeherder.mozilla.org/logviewer.html#?job_id=5077501&repo=try
https://treeherder.mozilla.org/logviewer.html#?job_id=5077492&repo=try
Flags: needinfo?(spohl.mozilla.bugs)
(Reporter)

Comment 1

3 years ago
Created attachment 8567309 [details]
mochitest-bc failure log
(Reporter)

Comment 2

3 years ago
https://hg.mozilla.org/try/raw-rev/a116b0b86186 is the raw diff for the patch if you want to test locally.
status-firefox37: --- → affected
status-firefox38: --- → affected
tracking-firefox37: ? → +
tracking-firefox38: ? → +
Assignee: nobody → spohl.mozilla.bugs
(Assignee)

Comment 3

3 years ago
I'm able to reproduce these failures locally. For some reason, when we run into these failures we're disabling Adobe EME after we enabled it via the pref... Still trying to make sense of it all.
Flags: needinfo?(spohl.mozilla.bugs)
(Assignee)

Comment 4

3 years ago
Created attachment 8567438 [details] [diff] [review]
Patch

Ok, looks like the media.eme.enabled pref is set to false by default when we're run as beta. The tests failed to force this pref to true during initialization and hence the tests failed. To be clear: the mistake was in our tests and the client code appears to be working as intended.
Attachment #8567438 - Flags: review?(gfritzsche)
(Assignee)

Comment 5

3 years ago
With this patch, all tests succeed with local builds on OSX and Linux.
Attachment #8567438 - Flags: review?(gfritzsche) → review+
(Assignee)

Comment 6

3 years ago
Thanks, Georg!

https://hg.mozilla.org/integration/mozilla-inbound/rev/c09d4b852a36
(Assignee)

Comment 7

3 years ago
Comment on attachment 8567438 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: Adobe EME
[User impact if declined]: When bug 1089867 merges to beta, GMP tests will start failing. We may therefore not be able to land bug 1089867 for Firefox 37 unless this patch lands at the same time.
[Describe test coverage new/current, TreeHerder]: Local testing showed that all issues discovered by RyanVM are fixed with this patch.
[Risks and why]: None that I'm aware of.
[String/UUID change made/needed]: none
Attachment #8567438 - Flags: approval-mozilla-aurora?
(Reporter)

Comment 8

3 years ago
https://hg.mozilla.org/mozilla-central/rev/c09d4b852a36
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox38: affected → fixed
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
(Reporter)

Comment 9

3 years ago
Verified on Try too :)
Status: RESOLVED → VERIFIED
status-firefox38: fixed → verified
(Reporter)

Comment 10

3 years ago
Comment on attachment 8567438 [details] [diff] [review]
Patch

Test-only changes don't need approval. Personally, I'd just include these fixes in the roll-up patch in the other bug.
Attachment #8567438 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 11

3 years ago
Thanks, Ryan! I've rolled it up into the patch for uplift in bug 1089867, but I'm unable to set the approval flag back to a+. Are you able to do so?
Flags: needinfo?(ryanvm)
(Reporter)

Comment 12

3 years ago
In this case, I think it's fine to just use the original approval since the only change was the test-only addition.
Flags: needinfo?(ryanvm)
(Reporter)

Updated

3 years ago
status-firefox37: affected → verified
You need to log in before you can comment on or make changes to this bug.