[Window Management][Music Widget] The music widget disappears when recording a video on on the lockscreen

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: DerekH, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing] 2.6UXnom, URL)

Attachments

(1 attachment)

Created attachment 8567334 [details]
Music Widget Logcat

Description:
The Music widget can get destroyed if the user is playing a song and then takes a video from the lockscreen and then returns to the lockscreen after taking the video


Repro Steps:
1) Update a Flame to 20150220010206
2) Open Music App> play a song
3) Press power button 1 time to sleep screen> Press power button again to wake screen
4) Slide lockscreen slider to the left to invoke camera app
5) Switch to Video> take a video> stop the video
6) Press power button 1 time to sleep screen> Press power button again to wake screen


Actual:
Music widget has disappeared, and is also absent from the notification tray.


Expected:
Music widget is available with controls for music on the lockscreen

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 10/10
See attached: Logcat, Video - http://youtu.be/_LYzT-YxD44
This issue DOES reproduce on Flame 2.2, 2.1, 2.0 and Base Image v18D-1

Music widget has disappeared, and is also absent from the notification tray

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150220002501
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: b864abe1c6b3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat)(Full Flash)
Build ID: 20150220001208
Gaia: 373df4bec2c20228f45be0b24111252171f925e9
Gecko: 10c100cba54d
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150219000202
Gaia: ecb1bbc3b9c00f82df172427f65d6f67e34ed533
Gecko: c76040f40105
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Environmental Variables:
Device: Flame Base Image v18D-1 (319mb)(Kitkat)
Build ID: 20150106124450
Gaia: 79f6218c4f30c2739575c3ab800078c2cda135cb
Gecko: d9d4000dd43a3637345a41d716dc97fdd700d715
Version: 32.0 (2.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
NI windows management owner for this.
Flags: needinfo?(gchang) → needinfo?(hcheng)
(In reply to Derek Harris [:DerekH] from comment #0)
> Created attachment 8567334 [details]
> Music Widget Logcat
> 
> Description:
> The Music widget can get destroyed if the user is playing a song and then
> takes a video from the lockscreen and then returns to the lockscreen after
> taking the video
> 
> 
> Repro Steps:
> 1) Update a Flame to 20150220010206
> 2) Open Music App> play a song
> 3) Press power button 1 time to sleep screen> Press power button again to
> wake screen
> 4) Slide lockscreen slider to the left to invoke camera app
> 5) Switch to Video> take a video> stop the video
> 6) Press power button 1 time to sleep screen> Press power button again to
> wake screen
> 

At STR step 5, the music is stopped after starting to take a video. However, it does not really pause the music. You can use task manager switch to music app and then it will automatically start playing the music and also bring the music widget back to lock screen...

NI notification designer and music developer for this issue.

> 
> Actual:
> Music widget has disappeared, and is also absent from the notification tray.
> 
> 
> Expected:
> Music widget is available with controls for music on the lockscreen
> 
> Environmental Variables:
> Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
> Build ID: 20150220010206
> Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
> Gecko: 1b4c5daa7b7a
> Gonk: e7c90613521145db090dd24147afd5ceb5703190
> Version: 38.0a1 (3.0)
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
> 
> Repro frequency: 10/10
> See attached: Logcat, Video - http://youtu.be/_LYzT-YxD44
Flags: needinfo?(hcheng)
Flags: needinfo?(epang)
Flags: needinfo?(dkuo)
I wouldn't expect the music player to disappear either.  Flagging Rob to help with the correct interaction.
Flags: needinfo?(epang) → needinfo?(rmacdonald)

Comment 6

3 years ago
I would say this is by design because when the music app gets interrupted, like another media app plays audio or camera app records video, which occupies the |content| audio channel, it hides the music widgets on the lockscreen and utility tray and means the music app is currently unavailable, unless the user bring the music app to foreground again and activates it.

Please see bug 973156 for detail, thanks.
Flags: needinfo?(dkuo)
See Also: → bug 973156
(In reply to Eric Pang [:epang] from comment #5)
> I wouldn't expect the music player to disappear either.  Flagging Rob to
> help with the correct interaction.

Rob, how do you think for this interaction behavior?
I can get this to repro on Flame 3.0 with a bit more troubling results where the user can see the music widget disappear, albeit in the notification tray instead of the lockscreen. Although STR is different, I am fairly sure it is the same bug.

Video of issue: http://youtu.be/eqryV7qlbm8

1) Launch music and select any option on the playlist tab
2) Pause music and return to homescreen
3) Launch video app and tap to play any video
4) While video is playing drag down notification tray
5) Tap play on music widget in notification tray

Actual result: User can briefly hear music playing, before cutting out a split second later while music widget disappears


Device: Flame 3.0
Build ID: 20150424010200
Gaia: 0c5e2ee1173f3c53379ef3cd10de714836258fe8
Gecko: 22a157f7feb7
Gonk: b83fc73de7b64594cd74b33e498bf08332b5d87b
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0
UX triage today:

If the Music app is open in the task manager, the Music widget should be shown both on the lockscreen and the notification tray. It should not be destroyed. 

Further, when another apps needs to use the audio channel (e.g. user taps to record a video ) music is paused. Music shouldn't resume. 

Thanks!
Flags: needinfo?(rmacdonald)
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing] 2.6UXnom

Comment 10

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.