[Dialer][USSD] MMI codes activated during a call do not function and will attempt to dial out as a number.

VERIFIED FIXED in Firefox 39

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: Marty, Assigned: aknow)

Tracking

({regression})

unspecified
2.2 S7 (6mar)
ARM
Gonk (Firefox OS)
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox37 wontfix, firefox38 wontfix, firefox39 fixed, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(5 attachments, 7 obsolete attachments)

43.82 KB, text/plain
Details
6.90 KB, patch
aknow
: review+
Details | Diff | Splinter Review
5.61 KB, patch
aknow
: review+
Details | Diff | Splinter Review
8.14 KB, patch
aknow
: review+
Details | Diff | Splinter Review
5.68 KB, patch
aknow
: review+
Details | Diff | Splinter Review
(Reporter)

Description

4 years ago
Description:
If the user tries to use an MMI code during a call, the code will not activate properly, but instead will try to dial out, resulting in the 'Your call cannot be completed as dialed...' telephony response.

-Notes:
-The IMEI code '*#06#' produces a 'generic failure' error message.
-The Change SIM PIN does not produce this error message
-Abbreviated Dialing Codes 'N(N)(N)#' do not cause this behavior, and function properly.

Repro Steps:
1) Update a Flame to 20150220010206
2) Make or receive a call from another device.
3) While in the call, tap the Home button to dismiss the Call Screen
4) Open the Dialer app
5) Input '*#06#' into the Dialer field.

Actual:
The active call is put on hold, and another call is started with the MMI code as dialed number, resulting in a telephony error message.

Expected:
The active call is not put on hold, and  the MMI code completes successfully

Environmental Variables:
Device: Flame 3.0 (319MB)(Full Flash)
Build ID: 20150220010206
Gaia: e4f7c67378e33e83f88d38ddb4a6c2cabf1423c3
Gecko: 1b4c5daa7b7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Repro frequency: 5/5
See attached: video clip (URL), logcat
(Reporter)

Comment 1

4 years ago
This issue DOES occur in Flame 2.2.
The active call is put on hold, and another call is started with the MMI code as dialed number, resulting in a telephony error message.

Environmental Variables:
Device: Flame 2.2 (319MB)(Full Flash)
Build ID: 20150219002504
Gaia: ce79d35b92261e7cbfeaefebf87859ebeb0979b4
Gecko: 159a3907b959
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

------------------------------

This issue does NOT occur in Flame 2.1 builds.
The active call is not put on hold, and  the MMI code completes successfully

Environmental Variables:
Device: Flame 2.1 (319MB)(Full Flash)
Build ID: 20150210002200
Gaia: 7dd130a312f12c89b2d41948f8557effa56afbf6
Gecko: 2de03dfa9aac
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Regression blocking functionality.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Triage: Regression which can lead to a certification blocker.
blocking-b2g: 2.2? → 2.2+
Whiteboard: [3.0-Daily-Testing] → [3.0-Daily-Testing][planned-sprint c=?]
Target Milestone: --- → 2.2 S7 (6mar)
We think that this is a RIL issue.

Gabriele, could you take a look and see if we're doing the right thing within Dialer code?
Flags: needinfo?(gsvelto)
Whiteboard: [3.0-Daily-Testing][planned-sprint c=?] → [3.0-Daily-Testing]
Target Milestone: 2.2 S7 (6mar) → ---
QA Contact: bzumwalt
On latest Flame 3.0 Mozilla-Central-Flame-KK-Engineering a separate issue occurs

When dialing code *#06# while in an existing call, the phone emits a single loud tone that plays continuously until user disconnects call. No error message is shown, no additional outbound call is made.

Leaving regressionwindow-wanted keyword until it is determined whether this is the same issue or not.

Device: Flame Master
Build ID: 20150223072338
Gaia: 288bf1c58ef9ccecd68508978a0141ee71974681
Gecko: 9b077c6f3d02
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This appears to be a different bug after consulting with Marty. I was opening dial pad from call instead of tapping to connect a new call. Will investigate issue described above later, finding regression window for this bug now.
Flags: needinfo?(ktucker)
Gecko B2G-Inbound Regression Window:

Last working B2G-Inbound build:
Device: Flame 2.2
Build ID: 20141211000715
Gaia: 335e30af4c1c4eab4886889fae82879d9c99899a
Gecko: 8d7362ccdb61
Version: 37.0a1 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

First broken B2G-Inbound build:
Device:  Flame 2.2
BuildID: 20141211002815
Gaia: 335e30af4c1c4eab4886889fae82879d9c99899a
Gecko: 65de6bc63a10
Version: 37.0a1 (2.2)
Firmware: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Working Gaia with Broken Gecko issue DOES reproduce:
Gaia: 335e30af4c1c4eab4886889fae82879d9c99899a
Gecko: 65de6bc63a10

Working Gecko with Broken Gaia issue does NOT reproduce:
Gaia: 335e30af4c1c4eab4886889fae82879d9c99899a
Gecko: 8d7362ccdb61


B2G-Inbound Pushlog:
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=8d7362ccdb61&tochange=65de6bc63a10


Issue appears to be caused by changes in bug 1093014
Flags: needinfo?(ktucker)
Szu-Yu Chen, can you take a look at this please? Looks like the work done for bug 1093014 might be the culprit here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(szchen)
(Assignee)

Updated

4 years ago
Assignee: nobody → szchen
Flags: needinfo?(szchen)
(Assignee)

Updated

4 years ago
Flags: needinfo?(gsvelto)
Component: Gaia::Dialer → RIL
(Assignee)

Comment 9

4 years ago
Working now.  Could fix the issue locally.  Just organize the code before formal review.
(Assignee)

Comment 10

4 years ago
Posted patch Part 1: Fix incall MMI issue (obsolete) — Splinter Review
Follow the flowchart on spec 3gpp ts 22.030 figure 3.5.3.2
Attachment #8568961 - Flags: review?(htsai)
(Assignee)

Comment 11

4 years ago
Posted patch Part 2: Test case (obsolete) — Splinter Review
Attachment #8568962 - Flags: review?(htsai)
(Assignee)

Comment 12

4 years ago
Posted patch Part 3: Fix typo (obsolete) — Splinter Review
Attachment #8568963 - Flags: review?(htsai)
Attachment #8568961 - Flags: review?(htsai) → review+
Comment on attachment 8568962 [details] [diff] [review]
Part 2: Test case

Review of attachment 8568962 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, thank you.
Attachment #8568962 - Flags: review?(htsai) → review+
Attachment #8568963 - Flags: review?(htsai) → review+
(Assignee)

Comment 14

4 years ago
Posted patch Part 1a: Fix defect in part 1 (obsolete) — Splinter Review
This should be an error in part 1.  I'll merge the patch into part 1 in the final version.  Just separate it now for easier review.
Attachment #8569046 - Flags: review?(htsai)
Comment on attachment 8569046 [details] [diff] [review]
Part 1a: Fix defect in part 1

Review of attachment 8569046 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you Orz

I believe eventually we need to put all MMI handling into a single place instead of having such fragile pieces as now.
Attachment #8569046 - Flags: review?(htsai) → review+
(Assignee)

Comment 16

4 years ago
Attachment #8569662 - Flags: review?(htsai)
(Assignee)

Comment 17

4 years ago
Attachment #8569663 - Flags: review?(htsai)
(Assignee)

Comment 18

4 years ago
Attachment #8569664 - Flags: review+
(Assignee)

Comment 19

4 years ago
Attachment #8568961 - Attachment is obsolete: true
Attachment #8568963 - Attachment is obsolete: true
Attachment #8569046 - Attachment is obsolete: true
Attachment #8569665 - Flags: review+
(Assignee)

Comment 20

4 years ago
Attachment #8568962 - Attachment is obsolete: true
Attachment #8569666 - Flags: review+
Attachment #8569662 - Flags: review?(htsai) → review+
Attachment #8569663 - Flags: review?(htsai) → review+
(Assignee)

Comment 23

4 years ago
merge part1a and part1b
Attachment #8569662 - Attachment is obsolete: true
Attachment #8569663 - Attachment is obsolete: true
Attachment #8571234 - Flags: review+
(Assignee)

Comment 24

4 years ago
Attachment #8569664 - Attachment is obsolete: true
Attachment #8571235 - Flags: review+
(Assignee)

Comment 25

4 years ago
Comment on attachment 8571234 [details] [diff] [review]
(2.2) [final] Part 1: Fix incall MMI issue. r=hsinyi

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression, bug 1093014 
User impact if declined: cannot use MMI code (ex: IMEI) during call
Testing completed: local test on flame
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: NA
Attachment #8571234 - Flags: approval-mozilla-b2g37?
(Assignee)

Comment 26

4 years ago
Comment on attachment 8571235 [details] [diff] [review]
(2.2) [final] Part 2: Test case. r=hsinyi

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): regression, bug 1093014 
User impact if declined: cannot use MMI code (ex: IMEI) during call
Testing completed: local test on flame
Risk to taking this patch (and alternatives if risky): low
String or UUID changes made by this patch: NA
Attachment #8571235 - Flags: approval-mozilla-b2g37?
(Assignee)

Updated

4 years ago
Keywords: leave-open
https://hg.mozilla.org/mozilla-central/rev/ce29ce7e1f99
https://hg.mozilla.org/mozilla-central/rev/214e70c97fcc
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S7 (6mar)
Attachment #8571234 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Attachment #8571235 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
This issue is verified fixed on the latest Nightly Flame 3.0 and 2.2 builds.

Actual Results: The codes produce the expected functionality when in a call.

Environmental Variables:
Device: Flame 3.0 KK (319MB) (Full Flash)
BuildID: 20150305010212
Gaia: eff3321ab4e65da3f906688ebb55ddf1e93d9452
Gecko: 56492f7244a9
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 39.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Environmental Variables:
Device: Flame 2.2 KK (319MB) (Full Flash)
BuildID: 20150305002528
Gaia: 89af288bad6751248ff84504fa898206fee127fe
Gecko: 6d8d294aa8f3
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.