Closed Bug 1135327 Opened 5 years ago Closed 5 years ago

[e10s] Warning NS_ENSURE_TRUE(node) fails frequently from nsDocumentViewer::GetInImage

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1058712

People

(Reporter: billm, Unassigned)

Details

Not sure where to file this. This assertion fails in the child process tens of thousands of times in each e10s mochitest run.

WARNING: NS_ENSURE_TRUE(node) failed: file /builds/slave/m-in-lx-d-00000000000000000000/build/src/layout/base/nsDocumentViewer.cpp, line 3523

This is the assertion in question:
http://mxr.mozilla.org/mozilla-central/source/layout/base/nsDocumentViewer.cpp#3523

Neil, can you hazard a guess what's going on here? It looks like it's in some controller code. It's firing so often that we might speed up our tests just by fixing or silencing it.
Flags: needinfo?(enndeakin)
It's not an assertion. Looks like GetPopupNode returns a node that isn't an image, or null?
Summary: [e10s] Assertion NS_ENSURE_TRUE(node) fails frequently from nsDocumentViewer::GetInImage → [e10s] Warning NS_ENSURE_TRUE(node) fails frequently from nsDocumentViewer::GetInImage
This is pretty much just 1058712.
Flags: needinfo?(enndeakin)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058712
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.