Closed Bug 1135348 Opened 5 years ago Closed 5 years ago

about:downloads broken

Categories

(Firefox :: Downloads Panel, defect)

38 Branch
x86_64
All
defect
Not set
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 39
Iteration:
39.1 - 9 Mar
Tracking Status
firefox37 --- unaffected
firefox38 + verified
firefox39 --- verified

People

(Reporter: alice0775, Assigned: mak)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/1b4c5daa7b7a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150220030202

Steps to reproduce:
1. Open about:downloads and download something

Actual results:
Download list is empty

And Error console shows following error:
ReferenceError: XPCOMUtils is not defined allDownloadsViewOverlay.js:7:0

ReferenceError: DownloadsCommon is not defined allDownloadsViewOverlay.js:510:2

TypeError: DOWNLOAD_VIEW_SUPPORTED_COMMANDS is undefined allDownloadsViewOverlay.js:1402:0

Expected results:
Download list should be displayed



Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=1d9dcfdb7c08&tochange=79fcb3f8f12e

Regressed by: Bug 1116176
Flags: needinfo?(paolo.mozmail)
Oops,
Regressed by: Bug 1129896
Blocks: 1129896
No longer blocks: 1116176
Duplicate of this bug: 1135343
The bunch of patches breaks "All-in-One Sidebar", "Download Manager (S3) ", "Downloads Window" and about:downloads.
I think the problem is that allDownloadsViewOverlay and downloads.js are using XPCOMUtils without importing it.
Flags: firefox-backlog+
Attached patch patch v1 (obsolete) — Splinter Review
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Flags: needinfo?(paolo.mozmail)
Attachment #8569794 - Flags: review?(paolo.mozmail)
Attached patch patch v1Splinter Review
Attachment #8569794 - Attachment is obsolete: true
Attachment #8569794 - Flags: review?(paolo.mozmail)
Attachment #8569795 - Flags: review?(paolo.mozmail)
Iteration: --- → 39.1 - 9 Mar
Flags: qe-verify?
Points: --- → 1
Flags: qe-verify? → qe-verify+
Comment on attachment 8569795 [details] [diff] [review]
patch v1

Thanks Marco for the patch, should have gotten to this earlier.

Sorry for the delay.
Attachment #8569795 - Flags: review?(paolo.mozmail) → review+
https://hg.mozilla.org/integration/fx-team/rev/7b738e0866a6
Target Milestone: --- → Firefox 39
Comment on attachment 8569795 [details] [diff] [review]
patch v1

Approval Request Comment
[Feature/regressing bug #]: Bug 1129896
[User impact if declined]: List of all downloads for Private Browsing windows is empty
[Describe test coverage new/current, TreeHerder]: Manual testing
[Risks and why]: The fix consists in restoring a simple missing module import
[String/UUID change made/needed]: None
Attachment #8569795 - Flags: approval-mozilla-aurora?
Attachment #8569795 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Contact: catalin.varga
Keywords: checkin-needed
Mistakenly filed against Firefox 38 and should be instead 38 Branch. Sorry for the spam. dkl
Version: Firefox 38 → 38 Branch
You need to log in before you can comment on or make changes to this bug.